Forum Debianizzati

Condividi contenuti
Aggiornato: 3 ore 19 min fa

Re: Installazione Libreoffice ... ho fatto un pastrocchio

Sab, 15/02/2020 - 21:05
a questo punto passo la palla
Categorie: Forum Debianizzati

Re: Installazione Libreoffice ... ho fatto un pastrocchio

Sab, 15/02/2020 - 20:52
il file libuno_sal.so.3 è parte del pacchetto uno-libs3. é installato?

credo di no, guarda il codice che segue:
 
# apt install --reinstall uno-libs3
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
La reinstallazione di uno-libs3 non è possibile, non può essere scaricato.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
#
Categorie: Forum Debianizzati

Re: Installazione Libreoffice ... ho fatto un pastrocchio

Sab, 15/02/2020 - 20:18
il file libuno_sal.so.3 è parte del pacchetto uno-libs3. é installato?
Categorie: Forum Debianizzati

Re: regolazione luminosità

Sab, 15/02/2020 - 18:38
è un'operazione che non credo di aver mai fatto.
il file che ho modificato questa volta è /boot/config-4.19.0-8-amd64
ho aggiunto la riga alla fine.
Categorie: Forum Debianizzati

b43/ucode15.fw

Sab, 15/02/2020 - 17:57
buongiorno a tutti.
sono poco pratico di debian, e non saprei risolvere quanto segue:
portatilino dell inspiron, oramai obsoleto, dovrei caricare il firmware b43/ucode15.fw su debian 10.3 .
ovviamente ci ho provato da solo, ma ottengo solo spiegoni lunghi diverse pagine e nessun link concreto, perlomeno, io non l'ho trovato. chiederei quindi
a) e' pacchettizzato oppure devoricompilarmenlo?
b) se e' pacchettizzato, potrei avere il link al pacchetto?
c) e' possibile farlo tramite apt-get ? con quale comando?
grazie a tutti/e
Categorie: Forum Debianizzati

Re: regolazione luminosità

Sab, 15/02/2020 - 15:45
mlibero ha scritto:[..] sto provando con l'pzione "nomodeset i915.modeset=0", spero di aver fatto bene, ho modificato il file grub.cdg così, veramente ci avevo già provato, ma mi era un po perso nel modificare grub all'avvio con l'opzione "e".
submenu 'Opzioni avanzate per Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-e6fb4c67-9efc-4207-869c-38aebf3216cd' {
   menuentry 'Debian GNU/Linux, con Linux 4.19.0-8-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.0-8-amd64-advanced-e6fb4c67-9efc-4207-869c-38aebf3216cd' {
      load_video 'nomodeset i915, modeset=0'
      insmod gzio

due riavvii e sembra che funzioni, bisogna però aspettare un po prima di dire che è risolto, perchè non ad ogni avvio si presenta il problema. aspetto qualche giorno.
Hai inserito i parametri nel posto sbagliato: li hai trattati come moduli di grub, mentre sono parametri del kernel.
Categorie: Forum Debianizzati

Re: esercitazioni col terminale andate storto

Sab, 15/02/2020 - 15:37
debjanus ha scritto:Si, ingenuamente purtroppo ero proprio in root, procederò a reinstallare il Sistema Operativa, grazie mille per la risposta e per l'attenzione
Figurati. Inconvenienti di questo genere sono quasi normali in un processo di apprendimento, l'importante è farne tesoro per il futuro. D'altro canto, con un sistema con Debian, a differenza dei sistemi operativi proprietari, si ha sempre disponibile il software per re-installare. Diverso è il discorso per i dati utente presenti nel sistema, da cui l'opportunità di poter sempre disporre di un backup per i dati che non è possibile perdere. Happy hacking & happy Debian.
Categorie: Forum Debianizzati

Re: Installazione Libreoffice ... ho fatto un pastrocchio

Sab, 15/02/2020 - 14:57

$ libreoffice
cosa dice?

$ libreoffice
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory



edit:
se non parte, come credo, prova a reinstallare anche
libreoffice-writer libreoffice-calc libreoffice-impress libreoffice-draw libreoffice-base libreoffice-math libreoffice-base-core uno-libs3 ure

Fatto. ma la sostanza non cambia.

Correggetemi se sbaglio credo che alla luce dei post trascorsi le da porsi siano le seguenti:
Domanda (1)
Perche quando ho disinstallato con l'opzione apt ... --purge
# apt remove --purge libreoffice-*
# apt-get remove --force --purge libreoffice

non si sono cancellati tutti i file e le cartelle e non si sono sistemati i file di configurazione?

Domanda (2)
Perché installando e reinstallando non si sono ripristinati tutti i pacchetti coerentemente con il sistema operativo?
# apt install --reinstall libreoffice-writer libreoffice-calc libreoffice-impress libreoffice-draw libreoffice-base libreoffice-math libreoffice-base-core uno-libs3
# apt install --reinstall -f libreoffice
# apt reinstall libreoffice



Domanda (3)
questo messaggio di errore a cosa fa riferimento? esistono delle operazioni che lo sanano?
$ libreoffice
/usr/lib/libreoffice/program/oosplash: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory
Categorie: Forum Debianizzati

Re: regolazione luminosità

Sab, 15/02/2020 - 13:15
col kernel 5.4 scaricato da backports non è cambiato niente, ora sto provando con l'pzione "nomodeset i915.modeset=0",
spero di aver fatto bene, ho modificato il file grub.cdg così, veramente ci avevo già provato, ma mi era un po perso nel modificare grub all'avvio con l'opzione "e".
submenu 'Opzioni avanzate per Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-e6fb4c67-9efc-4207-869c-38aebf3216cd' {
   menuentry 'Debian GNU/Linux, con Linux 4.19.0-8-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.0-8-amd64-advanced-e6fb4c67-9efc-4207-869c-38aebf3216cd' {
      load_video 'nomodeset i915, modeset=0'
      insmod gzio

due riavvii e sembra che funzioni, bisogna però aspettare un po prima di dire che è risolto, perchè non ad ogni avvio si presenta il problema.
aspetto qualche giorno.
Categorie: Forum Debianizzati

Re: esercitazioni col terminale andate storto

Sab, 15/02/2020 - 12:45
Si, ingenuamente purtroppo ero proprio in root, procederò a reinstallare il Sistema Operativo, grazie mille per la risposta e per l'attenzione
Categorie: Forum Debianizzati

Re: esercitazioni col terminale andate storto

Sab, 15/02/2020 - 12:25
debjanus ha scritto:Buonasera, sono un utente abbastanza nuovo di linux e questa sera mi esercitavo ad utilizzare il terminale con i comandi base, ovvero eliminare file e directory.
Volevo eliminare il contenuto di una directory di nome prova e ho inserito questo comando:
rm prova /* oppure questo rm prova ./*
L'outout successivo mi ha molto insospettito perchè c'era scritto:
impossibile cancella etc perchè è una directory
impossibile cancellare ___ perchè è una directorry
impossibile cancellare ____ perchè è una directory.... ed altre directory che si trovano in root. Allora ho pensato ma non è che ho ricevuto questo outout perchè sì certo non sono state cancellate le directory ma TUTTI I FILE di debian???
Dopo di questo volevo controllare provando ad entrare nel file manger manualmente, ma non era possibile entrare, anche da terminale tornando alla home cd ~ e digitando ls non mi dava risultato, era tutto macchinoso allora ho riavviato il sistema spegnendo la macchina manualmente perchè era tutto bloccato. Ai riavvii successivi non si avvia e mi da questo errore:
!! Failed to execute /sbin/init
!!!!!! Faile to exrcute fallback shell.
Secondo voi ho creato un danno serio cancellando tutti i file necessari al funzionamento e sono costretto a reinstallare, cosa mi consigliereste?
Dagli errori che hai indicato nelle ultime linee del messaggio precedente sembrerebbe che hai cancellato file indispensabili al funzionamento del sistema operativo. Ad esempio, /sbin/init è il primo programma ad essere avviato dal sistema operativo e che avvia tutti gli altri. Peraltro, per cancellare file come questi, proprio per non incorrere in situazioni come la tua, è indispensabile utilizzare l’utenza amministrativa di root, con la quale è sempre bene prestare molta attenzione durante l’utilizzo di tutti comandi ed in particolare del comando rm. Ed è per questo che l’utenza di root dovrebbe essere utilizzata solo nei casi strettamente necessari, ed utilizzare in tutti gli altri casi utenze ordinarie (non amministrative). Avendo, quindi, utilizzato l’utenza di root, è molto probabile che hai cancellato un gran numero di file indispensabili al sistema operativo.

Di conseguenza, non puoi che re-installare il sistema operativo.
Categorie: Forum Debianizzati