Forum Debianizzati

Condividi contenuti
Aggiornato: 1 ora 20 min fa

Re: errore nella realizzazione di una vpn

Ven, 12/07/2019 - 10:55
Mi sembra proprio strano.
Questi tre comandi che dicono?
$ ls -l /etc/openvpn/server.conf
$ cat /etc/openvpn/server.conf | wc -l
$ file /etc/openvpn/server.conf
Categorie: Forum Debianizzati

Re: pacchettizzare .deb

Ven, 12/07/2019 - 08:19
samiel ha scritto:Le operazione che partono da dh_make
presuppongono che abbia già dato il configure e il make del pacchetto?
Non necessariamente, solo opzionalmente per verificare che il sorgente si configuri e compili correttamente prima del dh_make. In tal caso, devi ricominciare con dh_make dal codice sorgente originale antecedente alla compilazione
Categorie: Forum Debianizzati

Re: pacchettizzare .deb

Ven, 12/07/2019 - 00:19
grazie, molto dettagliata.

una cosa che non capisco, o nonc'è all'nizio
o mi è sfuggita- Le operazione che partono da dh_make
presuppongono che abbia già dato il configure e il make del pacchetto?
Categorie: Forum Debianizzati

pacchettizzare .deb

Gio, 11/07/2019 - 22:41
Ho la necessità di pacchettizzare per bene un software,
e in passato ho effettuato questa operazione in fretta con checkinstall.
Ora invece vorrei fare le cose per bene,
e ho cercato in rete guide su questo tema.
Sono un po' disorientato, perché ce ne sono diverse
che risalgono dal 2010 in poi. Ora,
me ne potreste suggerire una aggiornata?

grazie
m
Categorie: Forum Debianizzati

Proposte di modifica alle guide trattanti i repository/APT

Gio, 11/07/2019 - 22:12
Proposte, aperte a discussione:
  1. aggiungere una nota (in box? senza?) che segnala l'avvenuto cambiamento a partire da testing dei repository sicurezza (da "bullseye/updates" a "bullseye-security");
  2. aggiungere i repository degli aggiornamenti raccomandati ("buster-updates", precedentemente "volatile") alla stable a tutte le configurazioni suggerite, seguendo le impostazioni di default decise dai Debian Developer a partire da Debian 10 (buster);
  3. adottare lo stesso mirror di default (attualmente "deb.debian.org"); l'argomento è già stato discusso in passato quando l'HTTP redirector era stato introdotto, ma il default allora era "ftp.XX.debian.org" e i Debian Developer avevano espressamente ritenuto prematuro cambiare tale default; la differenza ovviamente è minima, e per i più veloci è sempre meglio testarli come indicato dalla guida, ma perché averne uno diverso?
  4. cambiare le informazioni sull'HTTP redirector per riferirsi a "deb.debian.org", l'attuale forma preferita;
  5. adottare apt come nuovo comando di default ovunque possibile (limitatamente alle principali sui Repository) per l'uso interattivo (è default fin da Jessie, l'attuale oldoldstable supportata via LTS, quindi presente per tutte le versioni), in modo da uniformare il più possibile le guide principali di APT/Repository; tanto più che ora è anche indicato anche nelle note di rilascio per effettuare l'aggiornamento da stretch a buster;
  6. segnalare la possibilità di far operare APT in una sandbox (basta un singolo parametro in apt.conf) a partire da Debian 10 (buster); non tutte le funzionalità sono supportate, ma le principali sì.
Categorie: Forum Debianizzati

Re: errore nella realizzazione di una vpn

Gio, 11/07/2019 - 20:15
si, seguendo la guida, il server.conf che proponeva era fatto cosi...
ho provato a cambiare con auth SHA256 e a commentarla eseguendo di nuovo
systemctl start openvpn@server

ma continua a dare lo stesso errore..
Categorie: Forum Debianizzati

Re: errore nella realizzazione di una vpn

Gio, 11/07/2019 - 19:40
La riga 324 l'hai aggiunta tu?
Categorie: Forum Debianizzati

Re: errore nella realizzazione di una vpn

Gio, 11/07/2019 - 18:47
ciao, grazie per avermi risposto..
il problema è che quella riga non c'è, nel file, che riporto in allegato perchè altrimenti troppo lungo, ci sono solo 324 righe...
a meno che lui non conta come riga anche un commento fatto su una riga libero..spero di aver reso l'idea..

ps:ho allegato creando un archivio bz2, non mi fa allegare direttamente un txt
Categorie: Forum Debianizzati

Re: nvidia gt630: driver nouveau e proprietari nvidia

Gio, 11/07/2019 - 18:08
Lo script a cui mi riferisco è questo:
http://guide.debianizzati.org/index.php ... i_al_forum
Pensavo lo avessi già usato in passato, per cui non ho specificato a dovere. Scusa.
Categorie: Forum Debianizzati

Re: errore nella realizzazione di una vpn

Gio, 11/07/2019 - 17:13
Come riporta il log, ci deve essere un errore alla riga 328 di "/etc/openvpn/server.conf".
Categorie: Forum Debianizzati

Re: GUI non parte all'avvio dopo aggiornamento

Gio, 11/07/2019 - 16:39
ok grazie ho eseguito l'upgrade a debian 10 e ho installato il pacchetto
libgl1-mesa-dri
ora sembra che il sistema funzioni.
All'avvio viene correttamente lanciata la login grafica e anche l'ambiente desktop è correttamente disponibile
Categorie: Forum Debianizzati

Re: Stato delle guide dopo il rilascio di Debian 10 (buster)

Gio, 11/07/2019 - 16:12
s3v ha scritto:Ma dove è stata documentata la modifica dei repository security per testing?
Non è chiara la situazione ma sia nelle FAQ che in altre pagine di Debian si parla di "security" al posto di "update", Comunque una nota a riguardo la si trova qua https://wiki.debian.org/Status/Testing
(Controllando la cronologia delle pagine è stato proprio aggiunta per l'attuale testing.)

In italiano https://wiki.debian.org/it/Status/Testing
Categorie: Forum Debianizzati

Re: Debian 10 ed Amarok

Gio, 11/07/2019 - 15:46
mrdebug ha scritto:Come mai l'han toldo?
Alcune informazioni le puoi leggere qua https://tracker.debian.org/pkg/amarok

Mentre la segnalazione di bug che ha portato alla rimozione di Amarok da Buster è questa https://bugs.debian.org/cgi-bin/bugrepo ... bug=784448
Categorie: Forum Debianizzati

Apache: redirect porta 80 su altro server in https

Gio, 11/07/2019 - 15:21
Buon giorno a tutti, immaginate di avere un firewall che redirige la porta 80 su un apache 2.4 su una debian.
Oltre a questo webserver, nella rete locale vi è un altro server con una una webmail.
La porta 443 dello stesso ip pubblico è rediretta verso la webmail.

80 -> webserver
443 -> webmail

Sfortuna vuole che non avete un altro ip pubblico da dedicare alla webmail.
Questo impedisce a chi digita sul browser wemail.domain.com di raggiungere il servizio voluto, al contrario verrà mostrata una pagine del webserver.

Come workaround vorrei impostare un redirect su apache in modo che reinderizzi le richieste sulla 80 per l'url http://webmail.domain.com verso https//:webmail.domain.com.

Ahimé non ho grande confidenza con apache.
Leggendo la documentazione di apache e questo articolo sono giunto a questa conclusione:

<VirtualHost *:80>
  ServerName webmail.domain.com
  Redirect permanent / https://www.webmail.domain.com/
</VirtualHost>


Nel mio caso è bene che venga usata la redirezione permanente (301) anziché la temporanea di default (302).
Non credo mi serva definire un serverAlias.
Mi sfugge qualcosa o avete altri suggerimenti / considerazioni?

Grazie in anticipo.
Categorie: Forum Debianizzati

Re: GUI non parte all'avvio dopo aggiornamento

Gio, 11/07/2019 - 14:19
Il pacchetto "libgl1-mesa-dri" è installato?
# dpkg -l | grep -i libgl1-mesa-dri
altrimenti lo installi e riporti gli eventuali messaggi di errore.
Categorie: Forum Debianizzati

Re: GUI non parte all'avvio dopo aggiornamento

Gio, 11/07/2019 - 12:51
AGGIORNAMENTO

Ho provato a eseguire:

startx


e

xinit


Ma nessuno dei due comandi funziona. Ecco il messaggio di errore:

(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul 11 12:07:19 2019
(==) Using system config directory "/usr/share/x11/xorg.conf.d"
gbm: failed to open any driver (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/i965_dri.so: cannot open shared object file: No such file or directory
failed to load driver: i965
gbm: failed to open any driver (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/kms_swrast_dri.so: cannot open shared object file: No such file or directory
failed to load driver: kms_swrast
gbm: failed to open any driver (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory
failed to load swrast driver
couldn't get display device
xinit: Unable to run program "xterm": No such file or directory
Specify a program on the command line or make sure that /usr/bin is in your path
 
xinit: connection to X server lost
 
waiting for X server to shut down. terminated succesfully


la scheda video è una intel 4000,
ecco l'output di
 lshw -c video


*-display
    description: VGA compatible controller
    product: 3rd Gen Core processor Graphics Controller
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:00:02.0
    version: 09
    width: 64 bits
    clock: 33Mhz
    capabilities: msi pm vga_controller bus_master cap_list rom
    configuration: driver=i915 latency=0
    resources: irq:32 memory ... ecc


qualcuno ha qualche idea?

AGGIORNAMENTO

ho provato a reinstallare GNOME ed ora al boot non vengo dirottato nemmeno sulla modalità tty,
ma ottengo schermata nera, posso accedere al terminale solo entrando in modalità recovery
Categorie: Forum Debianizzati

Re: Stato delle guide dopo il rilascio di Debian 10 (buster)

Gio, 11/07/2019 - 12:50
Ne stiamo parlando qui: viewtopic.php?f=42&t=55163

Ma dove è stata documentata la modifica dei repository security per testing?
Categorie: Forum Debianizzati

Re: Debian Buster e Gnome

Gio, 11/07/2019 - 11:28
Ciao, grazie per la risposta.
Gnome Tweaks l'ho installato, ma non mi consente di fare ne l'una ne l'altra cosa.
I file css dei temi sono vuoti...
Se per esempio vado in /usr/share/themes/Adwaita/gtk-3.0/ trovo il file gtk.css ma al suo interno c'è solo questo:

/* Adwaita is now part of GTK+ 3, this file is no longer used */

Quindi non so più dove andare a cercare...

Quanto a XFCE l'ho usato per anni e lo trovo molto bello, diciamo pure che facevo tutto ciò che mi interessava senza problemi, dato che ho fatto un installazione pulita di buster volevo cambiare un pò... così... per avere un DE diverso... ma cavoli, hanno blindato anche le cose più banali!
Categorie: Forum Debianizzati