Forum Debianizzati

Condividi contenuti
Aggiornato: 19 min 16 sec fa

[RISOLTO]Suono sparito dopo aggiornamento del 21Giugno

Sab, 23/06/2018 - 12:05
Visto che ci si lamenta che ci sono pochi interventi, ho pensato di crearmi un problema :-)
A parte gli scherzi, con l'aggiornamento in oggetto non posso piu' scegliere in system-setting(kde) "Built In Audio Analog Stereo", devo usare forzatamente il dispositivo audio "GF108 High Definition Audio Controller Digital Sorround 7.1(HDMI)". Ma cosi' non ho il suono (forse perche' dovrei usare l'uscita digitale non i jack?). Anche lanciando system setting da root, tutte le varie opzioni di dispositivo audio sono in grigio, l'unica selezionabile e' quella HDMI che mi crea problemi. A livello di moduli, ho provato a verificarli con una lista memorizzata a sistema funzionante, ma non noto differenze, tutti i vari moduli del suono sono caricati.
Siccome avevo necessita' di far ripartire il sistema, non ho potuto fare molte altre verifiche, ho caricato con timeshift (a mio giudizio un grande programma ...) l'ultimo back up di sistema funzionante e via. Ora però non vorrei andare incontro allo stesso problema, aggiornando di nuovo. Qui sotto riporto parte del log apt dove si vede i pacchetti aggiornati/installati dall'aggiornamento del 21. Come faccio a capire quale di questi ha causato il problema al dispositivo audio?
Start-Date: 2018-06-21  16:59:26    Commandline: apt full-upgrade   
Install: libcdio18:amd64 (2.0.0-2, automatic), pkg-config:amd64 (0.29-4+b1, automatic), fluid-soundfont-gm:amd64 (3.1-5.1, automatic), libiso9660-11:amd64 (2.0.0-2, automatic)
Upgrade: libmpv1:amd64 (0.27.2-1, 0.27.2-1+b1), timidity-daemon:amd64 (2.13.2-41, 2.14.0-3), libkf5networkmanagerqt6:amd64 (5.46.0-1, 5.47.0-1), dbus-x11:amd64 (1.12.8-2, 1.12.8-3), libisccfg160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), libdbus-1-3:amd64 (1.12.8-2, 1.12.8-3), gnupg-utils:amd64 (2.2.7-1, 2.2.8-1), python-samba:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), gpg-wks-client:amd64 (2.2.7-1, 2.2.8-1), libkf5modemmanagerqt6:amd64 (5.46.0-1, 5.47.0-1), oxygen-icon-theme:amd64 (5:5.46.0-1, 5:5.47.0-1), gnupg-l10n:amd64 (2.2.7-1, 2.2.8-1), libwbclient0:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), aspell-gl-minimos:amd64 (0.5-44, 0.5-45), dbus:amd64 (1.12.8-2, 1.12.8-3), libirs160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), bind9-host:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), speedtest-cli:amd64 (2.0.0-2, 2.0.2-1), libxmmsclient6:amd64 (0.8+dfsg-18.1+b4, 0.8+dfsg-18.1+b5), dnsutils:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), libcdio-cdda2:amd64 (10.2+0.94+2-2+b1, 10.2+0.94+2-2+b2), nano:amd64 (2.9.7-1, 2.9.8-1), gpg-wks-server:amd64 (2.2.7-1, 2.2.8-1), gpg:amd64 (2.2.7-1, 2.2.8-1), libisc169:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), mime-support:amd64 (3.60, 3.61), gcc-6-base:amd64 (6.4.0-17, 6.4.0-18), dirmngr:amd64 (2.2.7-1, 2.2.8-1), samba-libs:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libcdio-paranoia2:amd64 (10.2+0.94+2-2+b1, 10.2+0.94+2-2+b2), ppp:amd64 (2.4.7-2+2, 2.4.7-2+3), libisc-export169:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), samba-common:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libgcrypt20:amd64 (1.8.2-2, 1.8.3-1), liblwres160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), python-pkg-resources:amd64 (39.1.0-1, 39.2.0-1), gpgv:amd64 (2.2.7-1, 2.2.8-1), libkf5prison5:amd64 (5.46.0-1, 5.47.0-1), python3-pkg-resources:amd64 (39.1.0-1, 39.2.0-1), wpasupplicant:amd64 (2:2.6-16, 2:2.6-17), libsmbclient:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), smbclient:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), samba-common-bin:amd64 (2:4.8.2+dfsg-1, 2:4.8.2+dfsg-2), libdns-export1100:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), breeze-icon-theme:amd64 (4:5.46.0-1, 4:5.47.0-1), gnupg2:amd64 (2.2.7-1, 2.2.8-1), dictionaries-common:amd64 (1.27.4, 1.27.6), timidity:amd64 (2.13.2-41+b1, 2.14.0-3), libisccc160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), dbus-user-session:amd64 (1.12.8-2, 1.12.8-3), libpsm2-2:amd64 (10.3-37-1, 10.3.58-1), libbind9-160:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), gnupg:amd64 (2.2.7-1, 2.2.8-1), libdns1100:amd64 (1:9.11.3+dfsg-1, 1:9.11.3+dfsg-2), vcdimager:amd64 (0.7.24+dfsg-1, 2.0.1+dfsg-2), libjs-sphinxdoc:amd64 (1.7.4-1, 1.7.5-3), gpg-agent:amd64 (2.2.7-1, 2.2.8-1), libvcdinfo0:amd64 (0.7.24+dfsg-1, 2.0.1+dfsg-2), gpgconf:amd64 (2.2.7-1, 2.2.8-1), mplayer:amd64 (2:1.3.0-8, 2:1.3.0-8+b1), gpgsm:amd64 (2.2.7-1, 2.2.8-1), gstreamer1.0-plugins-ugly:amd64 (1.14.1-1, 1.14.1-1+b1), libdatrie1:amd64 (0.2.11-1, 0.2.12-1), libdatrie-dev:amd64 (0.2.11-1, 0.2.12-1)
End-Date: 2018-06-21  17:01:17   Start-Date: 2018-06-21  17:04:35
Commandline: apt autoremove
Remove: libcdio17:amd64 (1.0.0-2+b1), libiso9660-10:amd64 (1.0.0-2+b1)
End-Date: 2018-06-21  17:04:37

Qui alcune info sul mio sistema :
Host: debian Kernel: 4.16.0-2-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.12.5   Distro: Debian GNU/Linux buster/sid
Audio:     Card-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
Card-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel  Sound Server: ALSA v: k4.16.0-2-amd64
Categorie: Forum Debianizzati

Re: Richiesta verifica funzionalità registrazione nuovi uten

Ven, 22/06/2018 - 01:04
s3v ha scritto:Vado a memoria ma ultimamente ci sono stati problemi di invio email (e il processo di registrazione richiede proprio la risposta ad una email di conferma). Si potrebbe provare con un'iscrizione fittizia da parte di qualcuno. Preferibilmente un admin che poi ha la possibilità di eliminare l'account usato come prova di registrazione al forum.
Ho fatto una prova ed, effettivamente, finora (qualche ora) non è arrivata nessuna email di conferma della registrazione diversamente da come annunciato dal messaggio successivo al completamento della procedura di registrazione di un nuovo utente. Sembrerebbe, quindi, che il meccanismo di iscrizione di nuovi utenti sia bloccato. Chiedo cortesemente a qualcuno degli Admin di eseguire le verifiche del caso.
Categorie: Forum Debianizzati

Re: Richiesta verifica funzionalità registrazione nuovi uten

Gio, 21/06/2018 - 09:38
Vado a memoria ma ultimamente ci sono stati problemi di invio email (e il processo di registrazione richiede proprio la risposta ad una email di conferma).
Si potrebbe provare con un'iscrizione fittizia da parte di qualcuno. Preferibilmente un admin che poi ha la possibilità di eliminare l'account usato come prova di registrazione al forum.
Non escluderei l'assenza totale di nuove iscrizioni, ultimamente il forum è molto poco frequentato.
Categorie: Forum Debianizzati

Richiesta verifica funzionalità registrazione nuovi utenti

Mer, 20/06/2018 - 23:07
Ho notato che ad oggi 20 giugno 2018 risulterebbe che l’ultima nuova iscrizione di un utente al forum risalga allo scorso 19 maggio, quindi circa un mese fa. Andando ad analizzare la serie storica degli scrittI dall’inizio dell’anno, non mi sembra di aver osservato un andamento analogo, pur essendoci stati periodi in cui le iscrizioni sono fortemente diminuite. Questo dato si sovrappone grossolanamente, da quel poco che ho potuto osservare, ad un forte calo di richieste di supporto (praticamente assenti nell’analogo periodo). Mi sembra, infatti che, storicamente, la maggior parte delle richieste nel passato siano provenute da nuovi utenti, mentre sono stati pochi gli utenti storici che hanno generato nuove richieste (forse questo perché una gran parte di utenti si rivolge al forum per risolvere un problema contingente che, una volta risolto, esaurisce l’interesse verso il forum) . Se questo dato potrebbe, da un lato, essere spiegato in tanti modi diversi (tra cui, ad esempio, la stagionalità delle richieste di iscrizione che potrebbero diminuire nel periodo estivo in cui l’utenza scolastica preferisce trascorrere il proprio tempo fuori casa, o altri motivi diversi), mi sorge il sospetto che possano esserci in realtà anche problematiche tecniche legate alla piattaforma del forum. In particolare, invio la presente per chiedere cortesemente a chi ne ha facoltà di verificare se, in questo momento, è in corso un blocco, anche parziale, del sistema informatico di iscrizione al forum, sia esso stato involontariamente attivato da un amministratore, oppure conseguente ad uno dei tanti molteplici attacchi a cui è stato sottoposto il forum in questi ultimi mesi, anche in ragione del - mi sembra - mancato aggiornamento dei software su cui gira la piattaforma del forum, che potrebbe esporli a vulnerabilità magari note. Infine, chiederei di verificare se sono in essere altri condizioni tecniche legate alla configurazione del forum o della piattaforma sui gira che possono interferire o inabilitare l’accesso al forum (ad esempio regole di ban tali da impedire l’accesso ad utenti legittimati a farlo).
Categorie: Forum Debianizzati

Chown

Mer, 20/06/2018 - 11:34
Ho aperto qui la discussione per un problema che abbiamo sotto Windows:
l'immagine di Win10 fornita dal datore di lavoro ha come proprietario TrustedInstaller, perciò non riusciamo ad installare un certo numero di software e driver di periferiche nemmeno prima di inserire in dominio la workstation.

Abbiamo provato a cambiare il proprietario da TrustedInstaller a Administrator, ma il sistema blocca l'operazione.

C'è un modo di forzare la cosa con Linux?
Se accedessi al sistema con una distro live, il comando chown funzionerebbe?
Parliamo, ovviamente, di filesystem Ntfs, exFat o ReFs.

Grazie in anticipo
Categorie: Forum Debianizzati

URGENTE: Software libero a rischio in EU

Mer, 20/06/2018 - 09:42
Il software libero è sotto attacco all'interno dell'Unione Europea (UE).
La proposta di direttiva europea sul copyright rappresenta un grande rischio per il software libero e il suo sviluppo.
La commissione Affari Legali (JURI) del Parlamento Europeo voterà dal 20 al 21 giugno 2018 se continuare o meno a permetterci di costruire software online insieme.

I membri del Parlamento europeo vogliono trasformare piattaforme di upload come GitLab in "macchine di censura" che richiedono che i materiali caricati dagli utenti siano monitorati e automaticamente filtrati, un processo che impedisce il caricamento di codice modificato e riutilizzato.
Questa disposizione è coperta dall'articolo 13 della direttiva sul diritto d'autore.

Se l'articolo 13, incorporato nella proposta, diventasse una politica ufficiale, sarà impossibile per gli sviluppatori costruire sul codice di altri - che non è solo un duro colpo per lo sviluppo collaborativo del software libero, ma una spinta contro le libertà fondamentali di Software libero.
Il software non è libero a meno che non possa essere modificato e condiviso.
L'articolo 13 riguarderà tutti gli utenti del software libero, poiché lo sviluppo del software libero ne soffre, la qualità e la disponibilità di aggiornamenti, nuove funzionalità e nuovi programmi ne risentiranno.

Puoi aiutare a invertire la tendenza contro l'Articolo 13.
Contatta il tuo membro del Parlamento Europeo (Parlamento Europeo) prima del 20 giugno.
Puoi provare questa email di esempio:

Caro deputato,
sono un cittadino dell'UE e sono contrario all'articolo 13 della proposta di direttiva sul diritto d'autore.
L'articolo 13 è dannoso per lo sviluppo globale e libero del software, compreso quello che fornisce l'infrastruttura necessaria su scala internazionale.
Si prega di votare contro la direttiva sul copyright.
Cordiali saluti
FIRMA
https://www.gnu.org/philosophy/free-sw.html

Un elenco completo di deputati al Parlamento europeo è disponibile online:
http://www.europarl.europa.eu/meps/en/full-list.html
Categorie: Forum Debianizzati

Re: NEO LUG Genova ponente

Mer, 20/06/2018 - 09:29
ottimo, che bella iniziativa, auguri
Categorie: Forum Debianizzati

Re: dual boot windows 10, clonare partizioni x backup window

Dom, 17/06/2018 - 10:15
Nessun problema
Ho solo scritto come avrei fatto io, ci sono sempre diversi modi per fare una cosa poi ognuno sceglie quella che trova più' comoda, facile e mille altre ragioni.
Categorie: Forum Debianizzati

Re: dual boot windows 10, clonare partizioni x backup window

Ven, 15/06/2018 - 18:38
la differenza è che win quando lo installi, installa anche il boot manager e boot loader.
Con bios non chiede conferma e fa tutto da solo, sovrascrivendo grub.
ma con efi e gpt possono convivere pacificamente, o meglio da standard diversi boot manager e/o boot loader
Categorie: Forum Debianizzati

Re: dual boot windows 10, clonare partizioni x backup window

Ven, 15/06/2018 - 18:09
scusami ma non sono per nulla daccordo
1 innanzi tutto le partizioni non sono uefi ma gpt (efi o uefi è un firmware come lo era il bios ecc, mentre gpt è lo schema di partizionamento, mbr è il vecchio standard)
2 clonezilla supporta pienamente le partizioni NTFS
3 ci sono diversi tutorial in rete che spiegano come usare sia software non open sia clonezilla, a chi usa windows
4 la convivenza tra win e linux non è difficile, Personalmente in bios/mbr la ho dal 2003 e in uefi/gpt da 4 anni
5 ho scritto che la partizione sda4 M$ reserved che è di soli 16MB la copio con dd

scusa non voglio far polemica, ma sono in disaccordo con te
Categorie: Forum Debianizzati

Re: dual boot windows 10, clonare partizioni x backup window

Gio, 14/06/2018 - 13:50
Ciao
Io non userei clonezilla perche' tra partizioni UEFI, partizioni create da Windows, e problemi di licenza di Windows 10 non sono sicuro che un ripristino da una clonazione vada a buon fine.
Io userei le utility di Windows per creare un punto di backup e il disco di ripristino per il sistema operativo.
La convivenza di Windows e linux nella partizione UEFI non e' semplice nel caso in cui si reinstalli un sistema operativo.
Perlomeno io non sono riuscito a venirne fuori da una reinstallazione di Linux e ho dovuto reinstallare prima windows e poi linux da zero.
Categorie: Forum Debianizzati

dual boot windows 10, clonare partizioni x backup windows

Mer, 13/06/2018 - 17:34
ho un portatili in dual boot con windows 10 e debian.
sul primo ho
sda1 partizione EFI (aka fat32 con flag boot ed efi [ma si sa già])
sda2 / debian
sda3 swap-linux
sda4 M$ reserved partition fs sconosciuto appena 16 MB
sda5 basic partition data NTFS 100 GB (dovrebbe essere la partizione di windows)
sda6 NTFS <1GB

sda4 sda5 sda6 sono state create dall'installer di windows

voglio fare il backup di windows, perchè anche se lo uso circa 3/4 volte all'anno, si rovina cmq.
intendo usare clonezilla.
La domanda è:
quali partizioni devo clonare?

per quanto riguarda sda4 la posso anche copiare con dd tanto sono solo 16 MB.
Categorie: Forum Debianizzati

Re: ftp.it.debian.org/ estremamente lento

Mer, 13/06/2018 - 07:57
@origrafica: potresti, per cortesia, aggiornarci ?
Categorie: Forum Debianizzati

[Risolto] Problema aggiornamento - /usr/bin/dpkg error

Lun, 11/06/2018 - 16:26
Grazie mille delle risposte.
Usando remove ho risolto:)

Ciao ciao:)
Categorie: Forum Debianizzati

Re: Problema aggiornamento - /usr/bin/dpkg returned an error

Dom, 10/06/2018 - 18:46
Cioè mi vuole eliminare tutti ikernel che ho in /boot?no, semplicemente ti dice i pacchetti che non necessitano al sistema e che possono essere eliminati, dato che tu gli hai detto di fare l'autoremove

autoremove

# apt-get autoremove

Rimuove i pacchetti installati automaticamente e che non sono più necessari in quanto dipendenze solo di altri pacchetti rimossi.
Il messaggio con cui apt ci avverte della loro presenza è:

Il seguente pacchetto è stato installato automaticamente e non è più richiesto:
nomepacchetto1 nomepacchetto2 ...
Usare "apt-get autoremove" per rimuoverlo.

La lista dei pacchetti installati con status di "autoremove" può essere visualizzata con:

$ aptitude '~i ~g'

Questo comando può essere combinato con l'opzione "--purge" (vedere il paragrafo "Opzioni").

Specificando questo comando con il nome di uno o più pacchetti, si otterrà la loro rimozione e, contemporaneamente, la rimozione di tutti i pacchetti non più necessari. Vedere anche l'opzione "--auto-remove" e la direttiva "APT::Get::AutomaticRemove". Esempio:

# apt-get autoremove pacchetto1, pacchetto2 ... pacchettoN

Categorie: Forum Debianizzati

Re: Problema aggiornamento - /usr/bin/dpkg returned an error

Dom, 10/06/2018 - 12:26
non utilizzare l'opzione autoremove ma usa il comando base
# apt-get remove pacchetto1 pacchetto2 ... pacchettoN
oppure
# apt-get purge pacchetto1 pacchetto2 ... pacchettoN

in ogni caso guarda la guida http://guide.debianizzati.org/index.php/Apt-get
Categorie: Forum Debianizzati

[Risolto] Problema aggiornamento - /usr/bin/dpkg error

Dom, 10/06/2018 - 10:30
Ciao a tutti,
questa mattina stavo aggiornando la mia Debian Buster e dopo aver dato sudo aptitude safe-upgrade ho ricevuto questo output:
update-initramfs: Generating /boot/initrd.img-4.16.0-2-amd64

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.16.0-2-amd64 with 1.
dpkg: errore nell'elaborare il pacchetto initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Elaborazione dei trigger per libc-bin (2.27-3)...
Si sono verificati degli errori nell'elaborazione:
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
Configurazione di initramfs-tools (0.130)...
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per initramfs-tools (0.130)...
update-initramfs: Generating /boot/initrd.img-4.16.0-2-amd64

gzip: stdout: No space left on device
cpio: errore di scrittura: Pipe interrotta
E: mkinitramfs failure cpio 2 gzip 1
update-initramfs: failed for /boot/initrd.img-4.16.0-2-amd64 with 1.
dpkg: errore nell'elaborare il pacchetto initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Si sono verificati degli errori nell'elaborazione:
 initramfs-tools


Mi sembra di capire che ho la partizione /boot piena (usando LVM con full disk encryption ho la partizione di boot separata.

Devo quindi eliminare una qualche linux-image vecchia. Dando il comando aptitude search ~ilinux-image vedo che ho:

i A linux-image-4.14.0-3-amd64                   - Linux 4.14 for 64-bit PCs                             
i A linux-image-4.15.0-2-amd64                   - Linux 4.15 for 64-bit PCs                             
i A linux-image-4.15.0-3-amd64                   - Linux 4.15 for 64-bit PCs                             
i A linux-image-4.16.0-1-amd64                   - Linux 4.16 for 64-bit PCs                             
i A linux-image-4.16.0-2-amd64                   - Linux 4.16 for 64-bit PCs                             
i   linux-image-4.9.0-3-amd64                    - Linux 4.9 for 64-bit PCs                               
i A linux-image-4.9.0-5-amd64                    - Linux 4.9 for 64-bit PCs                               
i   linux-image-amd64                            - Linux per PC a 64 bit (metapacchetto)   


Provo ad eliminare l'immagine 4.9.0-3-amd64 (visto che non è una dipendenza), ma cmq output ho:
sudo apt-get autoremove linux-image-4.9.0-3-amd64
[sudo] password di leo:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  linux-image-4.14.0-3-amd64 linux-image-4.15.0-2-amd64 linux-image-4.15.0-3-amd64
  linux-image-4.9.0-3-amd64 linux-image-4.9.0-5-amd64
0 aggiornati, 0 installati, 5 da rimuovere e 5 non aggiornati.
1 non completamente installati o rimossi.
Dopo quest'operazione, verranno liberati 1'141 MB di spazio su disco.
Continuare? [S/n]

Cioè mi vuole eliminare tutti ikernel che ho in /boot? Prima di fare qualche cavolata ho risposto di "no".

Cosa mi consigliate di fare?

Ciao ciao leo:)
Categorie: Forum Debianizzati

Re: mariadb tabella che crasha

Sab, 09/06/2018 - 12:28
ho fatto un truncate delle tabelle
TRUNCATE `data_bin`;
TRUNCATE `index_data`;
TRUNCATE `metrics`;

e adesso pare a posto
amen
Categorie: Forum Debianizzati

Re: apt-get autoremove

Ven, 08/06/2018 - 09:54
Aggiunge dei dettagli in più.
Ho re-installato apache2 tramite 'apt-get install apache2'.
Mi sarei aspettato che i flag delle dipendenze si sarebbero sistemati, invece vedo:

aptitude search apache | grep -v ^p | grep -v ^v
iB  apache2                         - Apache HTTP Server                       
id  apache2-bin                     - Apache HTTP Server (modules and other bina
id  apache2-data                    - Apache HTTP Server (common files)         
id  apache2-utils                   - Apache HTTP Server (utility programs for w


Aprendo aptitude condiglia di rimuovere un pacchetto (apache2).
Queste sono le azioni che consiglia:

Premendo 'g' per rimuovere apache2 (da aptitude), rimuove anche le dipendeze

se invece eseguo aptitude da riga di comando, non rimuove le dipendeze "guaste".

aptitude remove apache2
I seguenti pacchetti saranno RIMOSSI:               
  apache2
0 pacchetti aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
È necessario prelevare 0 B di archivi. Dopo l'estrazione, verranno liberati 502 kB.
(Lettura del database... 95975 file e directory attualmente installati.)
Rimozione di apache2 (2.4.18-2ubuntu3.8)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Elaborazione dei trigger per ufw (0.35-0ubuntu2)...
Categorie: Forum Debianizzati

[RISOLTO] mariadb tabella che crasha

Ven, 08/06/2018 - 08:52
ho una VM con 2 vcpu, 3gb ram, mariadb 10.0.32, debian 8.10, centreon (una specie di nagios)
in /var/log/syslog ho:
Jun 8 08:30:06 cloro mysqld: 180608 8:30:06 [ERROR] mysqld: Table './centreon_storage/logs' is marked as crashed and should be repaired
Jun 8 08:30:06 cloro mysqld: 180608 8:30:06 [Warning] Checking table: './centreon_storage/logs'
Jun 8 08:30:10 cloro mysqld: 2018-06-08 08:30:10 7f13ad17c700 InnoDB: Assertion failure in thread 139722485122816 in file btr0cur.cc line 332
Jun 8 08:30:10 cloro mysqld: InnoDB: Failing assertion: btr_page_get_prev(get_block->frame, mtr) == page_get_page_no(page)
Jun 8 08:30:10 cloro mysqld: InnoDB: We intentionally generate a memory trap.
Jun 8 08:30:10 cloro mysqld: InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
Jun 8 08:30:10 cloro mysqld: InnoDB: If you get repeated assertion failures or crashes, even
Jun 8 08:30:10 cloro mysqld: InnoDB: immediately after the mysqld startup, there may be
Jun 8 08:30:10 cloro mysqld: InnoDB: corruption in the InnoDB tablespace. Please refer to
Jun 8 08:30:10 cloro mysqld: InnoDB: http://dev.mysql.com/doc/refman/5.6/en/ ... overy.html
Jun 8 08:30:10 cloro mysqld: InnoDB: about forcing recovery.
Jun 8 08:30:10 cloro mysqld: 180608 8:30:10 [ERROR] mysqld got signal 6 ;
Jun 8 08:30:10 cloro mysqld: This could be because you hit a bug. It is also possible that this binary
Jun 8 08:30:10 cloro mysqld: or one of the libraries it was linked against is corrupt, improperly built,
Jun 8 08:30:10 cloro mysqld: or misconfigured. This error can also be caused by malfunctioning hardware.

ma se faccio myisamchk /var/lib/mysql/centreon_storage/logs.MYI
Checking MyISAM file: /var/lib/mysql/centreon_storage/logs.MYI
Data records: 1072973 Deleted blocks: 0
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check data record references index: 3
- check data record references index: 4
- check data record references index: 5
- check data record references index: 6
- check data record references index: 7
- check data record references index: 8
- check data record references index: 9
- check data record references index: 10
- check record links

e se controllo la tabella con phpmyadmin mi dice che è ok

poi, avviando mysqltuner
[!!] Log file /var/lib/mysql/cloro.err is empty

in my.cnf c'è
general_log_file = /var/log/mysql/general.log
general_log = 1
log_error = /var/log/mysql/error.log


ps aux
root 599 0.3 0.2 24988 6268 ? S giu07 4:15 /bin/bash /usr/bin/mysqld_safe
mysql 16954 0.9 5.8 1612936 181808 ? Sl 08:30 0:10 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --skip-log-error --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
root 16955 0.0 0.0 23720 2392 ? S 08:30 0:00 logger -t mysqld -p daemon.error


infine da dentro il db
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+
| Variable_name | Value |
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+
| general_log | OFF |
| general_log_file | cloro.log |
| log_error | |
+-------------------------------------------+--------------------------------------------------------------------------------------------------------------+


quindi, in conclusione, non capisco:
1. sta tabella, è corrotta o no?
2. sti log, sono attivi o no?
3. il file di conf, viene letto o no?

forse c'è stato qualche casino nel passaggio da mysql a mariadb?
grazie
Categorie: Forum Debianizzati