Forum Debianizzati

Condividi contenuti
Aggiornato: 1 ora 12 min fa

Prestazioni inferiori al dovuto

Dom, 26/01/2020 - 21:42
Buongiorno,

spero di essere nella sezione corretta. Recentemente ho installato Debian e Windows 7 su due partizioni diverse. Per testare le prestazioni dei due sistemi operativi ho provato l'esecuzione di uno stesso videogioco, Empire Total War installato attraverso la piattaforma Steam (nel dettaglio ho seguito pedissequamente tutti i passaggi elencati qui: https://wiki.debian.org/Steam, compresi l'installazione del driver Nvidia e Mesa; sono entrambi necessari?). Purtroppo le prestazioni con il sistema Linux sono abbastanza deludenti, sopratutto per alcuni continui rallentamenti che avvengono durante il gameplay (nonostante i requisiti minimi siano abbondantemente soddisfatti per una completa fluidità devo abbassare al minimo le impostazioni grafiche). Ho forse mancato l'installazione di qualche Driver? Ogni suggerimento sarà ben gradito!

Allego le caratteristiche dettagliate del mio Hardware.

Grazie per l'attenzione e buona domenica.
Categorie: Forum Debianizzati

Re: Possible missing firmware

Dom, 26/01/2020 - 20:46
ma poi devo aggiornare initramfs?
mai fatto, per cui non vorrei fare grossi guai....
Categorie: Forum Debianizzati

Re: Possible missing firmware

Dom, 26/01/2020 - 20:20
samiel ha scritto:grazie, fermo restando che non saprei come installarlo...
Copi il file in /lib/firmware/rtl_nic/
Categorie: Forum Debianizzati

Re: Possible missing firmware

Dom, 26/01/2020 - 20:15
grazie, fermo restando che non saprei come installarlo...
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 19:40
Piergiusepegiorgio ha scritto:
grep -r -i eth0 /etc/network/*
/etc/network/interfaces.d/setup:auto eth0
/etc/network/interfaces.d/setup:iface eth0 inet dhcp

Il "colpevole" dell'errore di avvio del servizio networking.service è questo file chiamato /etc/network/interfaces.d/setup che non fa parte della ordinaria installazione di Debian e che presumibilmente consegue ad una creazione manuale da parte dell'utente oppure alla installazione di pacchetti di terze parti. Dovresti poter cancellare il file /etc/network/interfaces.d/setup senza particolari problemi.
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 19:31
Aki ha scritto:cattiware ha scritto:Aki ha scritto:Puoi indicare la versione del kernel di ubuntu ?
Non mi ricordo che versione del kernel avevo su Ubuntu perché al momento non c'è l'ho installato, ma son sicuro che la versione è maggiore di quella della Debian 10 Stable. [..] Per me è già "risolto", nel senso che ho capito il problema...
Felice tu abbia risolto. Nel frattempo, se con Debian Stable desideri utilizzare un kernel più recente di quello utilizzato di default, puoi utilizzare i repository debian-backports, da cui puoi attualmente installare la versione del kernel 5.4.8.
Cavolo, non sapevo si potesse fare!! Fantastico, provo e so dire...
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 19:21
grep -r -i eth0 /etc/network/*
/etc/network/interfaces.d/setup:auto eth0
/etc/network/interfaces.d/setup:iface eth0 inet dhcp
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 19:04
cattiware ha scritto:Aki ha scritto:Puoi indicare la versione del kernel di ubuntu ?
Non mi ricordo che versione del kernel avevo su Ubuntu perché al momento non c'è l'ho installato, ma son sicuro che la versione è maggiore di quella della Debian 10 Stable. [..] Per me è già "risolto", nel senso che ho capito il problema...
Felice tu abbia risolto. Nel frattempo, se con Debian Stable desideri utilizzare un kernel più recente di quello utilizzato di default, puoi utilizzare i repository debian-backports, da cui puoi attualmente installare la versione del kernel 5.4.8.
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 18:45
Aki ha scritto:Puoi indicare la versione del kernel di ubuntu ?

Infatti, ho verificato anche con altri sistemi sistemi operativi (linux, debian-based e altro)...
Purtroppo è la versione del kernel linux di Debian.
Credo che proverò altre distribuzioni linux per il momento, mentre aspetto una'altra versione di Debian...

Comunque Debian era la 10.2 stabile con interfaccia KDE... (disinstallata...)

Non mi ricordo che versione del kernel avevo su Ubuntu perché al momento non c'è l'ho installato, ma son sicuro che la versione è maggiore di quella della Debian 10 Stable.

Ho provato anche MX Linux, che è una versione derivata di Debian 10 Stable, con lo stesso kernel: non funziona lo stato della batteria (e neanche le reti wireless...).

Per me è già "risolto", nel senso che ho capito il problema...
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 16:56
Piergiusepegiorgio ha scritto:/etc/network/interfaces in Debian:
source-directory /etc/network/interfaces.d

/etc/network/interfaces in Neon:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Anche nella tua installazione di Debian in /etc/network/interfaces scrivi solo:
auto lo
iface lo inet loopback

Inoltre, cerca se ci sono altre configurazioni "strane" in /etc/network/ con il comando:
script log.txt
grep -r -i eth0 /etc/network/*
exit
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 16:48
cattiware ha scritto:Aki ha scritto:Scusa la banalità della domanda, ma come fai a sapere che Debian non riconosce la batteria se non hai installato Debian che vorresti installare ?
L'ho installata, solo che ritengo l'installazione finita quando è tutto funzionante...
Potevi dirlo prima: che versione di Debian hai installato ?

Puoi fornire l'output dello script http://guide.debianizzati.org/index.php/Creazione_automatica_di_un_file_di_log_per_inviare_quesiti_al_forum ?

cattiware ha scritto:Per quanto riguarda la batteria (sto guardando da una versione di Ubuntu, su cui lo stato della batteria funziona):
- Produttore: CPT-COS
- Modello: L16C2PB2
Puoi indicare la versione del kernel di ubuntu ?
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 15:07
/etc/network/interfaces in Debian:
source-directory /etc/network/interfaces.d

/etc/network/interfaces in Neon:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 13:15
L'ho installata, solo che ritengo l'installazione finita quando è tutto funzionante...

La Debian ha interfaccia KDE

Per quanto riguarda la batteria (sto guardando da una versione di Ubuntu, su cui lo stato della batteria funziona):
- Produttore: CPT-COS
- Modello: L16C2PB2
Categorie: Forum Debianizzati

Possible missing firmware

Dom, 26/01/2020 - 11:44
Sono su Sid con Cinnamon. Da qualche settimana quando viene effettuato update-initramfs ricevo:
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125a-3.fw for module r8169

il che dovrebbe riferirsi a un hardware realtek. Infatti
root@darkstar:~# dmesg | grep -Ei "firmware|fw"
[    0.166003] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.292140] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    5.904298] r8169 0000:03:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-2.fw

e
apt update && apt search rtl8168e-3.fw
.
.
.
firmware-realtek/unstable,now 20190717-2 all [installato]
  Binary firmware for Realtek wired/wifi/BT adapters

Eppure
root@darkstar:~# apt install firmware-misc-nonfree firmware-realtek
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
firmware-misc-nonfree è già alla versione più recente (20190717-2).
firmware-realtek è già alla versione più recente (20190717-2).
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Cos'altro mi manca da installare?
grazie
m
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 09:26
cattiware ha scritto:Salve, sono possessore di un laptop IdeaPad S145 e vorrei installarci l'ultima versione di Debian GNU/Linux... sfortunatamente c'è IdeaPad S145 problema, e non ne vengo a capo: il sistema operativo non mi riconosce la batteria... Ho provato a cercare la directory della batteria:
/sys/class/power_supply/BAT0

ma non esiste, è sostituita da:
ADP0

Scusa la banalità della domanda, ma come fai a sapere che Debian non riconosce la batteria se non hai installato Debian che vorresti installare ?
Categorie: Forum Debianizzati

LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 03:08
Salve, sono possessore di un laptop IdeaPad S145 e vorrei installarci l'ultima versione di Debian GNU/Linux... sfortunatamente c'è un problema, e non ne vengo a capo: il sistema operativo non mi riconosce la batteria...

Ho provato a cercare la directory della batteria:
/sys/class/power_supply/BAT0

ma non esiste, è sostituita da:
ADP0


Un'altra informazione che potrei dare è che ho inserito in "blacklist" il modulo
ideapad_laptop
per far riconoscere al sistema le reti wireless...

Attendo risposte...
Grazie.

Alessandro
Categorie: Forum Debianizzati

Re: DELL G3 15 3590 & nVidia GTX 1050 problema utilizzo

Dom, 26/01/2020 - 00:56
Puoi usare lo script http://guide.debianizzati.org/index.php/Creazione_automatica_di_un_file_di_log_per_inviare_quesiti_al_forum ma dovresti prima indicare “cosa non va” nella sezione video dei tuo computer.
Categorie: Forum Debianizzati

Re: DELL G3 15 3590 & nVidia GTX 1050 problema utilizzo

Sab, 25/01/2020 - 23:04
Aki ha scritto:alexsgv ha scritto:[..] mi sono accorto che qualcosa non va.[..] La scheda la vede ma non capisco cosa non vada.
Mi sembra una descrizione tecnica "leggermente ermetica" di quanto hai riscontrato

Ciao, si mi rendo conto...quali strumenti posso usare per capire cosa non va? Non sono molto ferrato sulla cosa...
Categorie: Forum Debianizzati

Re: DELL G3 15 3590 & nVidia GTX 1050 problema utilizzo

Sab, 25/01/2020 - 22:12
alexsgv ha scritto:[..] mi sono accorto che qualcosa non va.[..] La scheda la vede ma non capisco cosa non vada.
Mi sembra una descrizione tecnica "leggermente ermetica" di quanto hai riscontrato
Categorie: Forum Debianizzati