Forum Debianizzati

Condividi contenuti
Aggiornato: 49 sec fa

Re: Server X non si avvia GeForce GT 320M

3 ore 52 min fa
Quindi come procedo? Cancello tutta la configurazione presente in home?
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

4 ore 58 min fa
Dall'ultimo log che hai inviato risulta che per Debian prima delle variazioni alla configurazione la critical-chain era:
graphical.target @13.323s
└─multi-user.target @13.323s
  └─exim4.service @12.318s +1.004s
    └─network-online.target @12.314s
      └─NetworkManager-wait-online.service @3.230s +9.083s
        └─NetworkManager.service @1.004s +2.224s
          └─dbus.service @997ms
            └─basic.target @966ms
              └─sockets.target @966ms
                └─dbus.socket @966ms
                  └─sysinit.target @964ms
                    └─systemd-timesyncd.service @713ms +251ms
                      └─systemd-tmpfiles-setup.service @614ms +95ms
                        └─systemd-journal-flush.service @583ms +29ms
                          └─systemd-journald.service @441ms +140ms
                            └─syslog.socket @439ms
                              └─system.slice @424ms
                                └─-.slice @424ms
e dopo le variazioni è:
graphical.target @3.743s
└─udisks2.service @900ms +2.841s
  └─basic.target @899ms
    └─sockets.target @899ms
      └─avahi-daemon.socket @898ms
        └─sysinit.target @895ms
          └─systemd-backlight@backlight:acpi_video0.service @794ms +100ms
            └─system-systemd\x2dbacklight.slice @720ms
              └─system.slice @286ms
                └─-.slice @286ms

Risulta, quindi, che in Debian sei passato da 13.323 secondi a 3.743 secondi per l'attivazione del graphical.target che corrisponde all'attivazione del sistema grafico (comparsa della finestra di login del desktop enviroment).
Categorie: Forum Debianizzati

Re: Installazione pacchetti bloccati

Mer, 29/01/2020 - 00:29
Nello script http://guide.debianizzati.org/index.php/Creazione_automatica_di_un_file_di_log_per_inviare_quesiti_al_forum è presente una sezione per l’identificazione dei pacchetti provenienti da repository di terze parti e, quindi, potresti verificare se riesci ad identificare quelli che provengono dai repository debmultimedia.
Categorie: Forum Debianizzati

Re: Server X non si avvia GeForce GT 320M

Mer, 29/01/2020 - 00:17
Sembrerebbe che ci sia un parametro errato passato in un file di configurazione al modulo del kernel nvidia che impedisce l'attivazione degli ulteriori moduli del kernel per la scheda grafica.
Categorie: Forum Debianizzati

Re: Installazione pacchetti bloccati

Mar, 28/01/2020 - 15:28
Aki ha scritto:capocla ha scritto:Sapreste dirmi se c'è un modo di togliere tutti e solo i software di un determinato repository?
Dai una occhiata allo script per la generazione dei log: in esso è implementata la funzionalità per cercare di verificare la presenza di pacchetti esterni ai repository Debian
Potresti spiegarti meglio?
Categorie: Forum Debianizzati

Server X non si avvia GeForce GT 320M

Mar, 28/01/2020 - 15:27
Salve,
come da titolo, il server X non viene avviato. È da qualche mese che ho questo problema su un computer secondario. Ho sperato che gli aggiornamenti successivi lo avrebbero risolto senza successo. Premetto di utilizzare una cheda video nvidia GeForce GT 320M su debian testing
Durante l'avvio, il pc restituisce i seguenti errori nel log
# vat /var/log/boot.log |grep FAILED
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start Load Kernel Modules.
[FAILED] Failed to start NVIDIA Persistence Daemon.

Questo, invece, è l'output del comando
#  systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
     Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
     Active: failed (Result: exit-code) since Tue 2020-01-28 14:01:49 CET; 6min ago
       Docs: man:systemd-modules-load.service(8)
             man:modules-load.d(5)
    Process: 490 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
   Main PID: 490 (code=exited, status=1/FAILURE)

gen 28 14:01:49 debian-hp systemd-modules-load[495]: modprobe: ERROR: could not insert 'nvidia': Invalid argument
gen 28 14:01:49 debian-hp systemd-modules-load[510]: modprobe: ERROR: could not insert 'nvidia_current_modeset': N>
gen 28 14:01:49 debian-hp systemd-modules-load[493]: modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do()>
gen 28 14:01:49 debian-hp systemd-modules-load[493]: modprobe: ERROR: could not insert 'nvidia_modeset': Invalid a>
gen 28 14:01:49 debian-hp systemd-modules-load[513]: modprobe: ERROR: could not insert 'nvidia_current_drm': No su>
gen 28 14:01:49 debian-hp systemd-modules-load[490]: Error running install command 'modprobe nvidia-modeset ; modp>
gen 28 14:01:49 debian-hp systemd-modules-load[490]: Failed to insert module 'nvidia_drm': Invalid argument
gen 28 14:01:49 debian-hp systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAI>
gen 28 14:01:49 debian-hp systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
gen 28 14:01:49 debian-hp systemd[1]: Failed to start Load Kernel Modules.


Il comand dpkg-reconfigure nvidia-kernel-dkms sembra non restituire errori.
Infine il driver installato è il nvidia-legacy-340xx-driver

Grazie
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Lun, 27/01/2020 - 19:43
Grazie,
Categorie: Forum Debianizzati

Trasferimento di fondi PayPal, Banca e WU.

Lun, 27/01/2020 - 12:27
Venditore legittimo per il trasferimento di fondi PayPal, Banca e WU.
Acquista trasferimenti di fondi PayPal e Alipay sicuri al 100%.
Conto PayPal verificato e sicuro al 100%. Trasferimento in tutto il mondo ad eccezione dei paesi vietati / inseriti nella lista nera.

PayPal
Prezzo dell'importo del trasferimento
€ 5.000 Trasferimento = € 700
€ 10.000 Trasferimento = € 1.400

Alipay
Prezzo dell'importo del trasferimento
¥ 38.000 CNY Transfer = ¥ 5600
¥ 76.000 CNY Transfer = ¥ 11.200

Contatta da:
Telegram: Digitalmarkt

controlla il canale su Telegram!
https://t.me/bestfinancialmarket
Categorie: Forum Debianizzati

Venditore legittimo per il trasferimento di fondi PayPal, Ba

Lun, 27/01/2020 - 12:23
Venditore legittimo per il trasferimento di fondi PayPal, Banca e WU.
trasferimenti di fondi PayPal e Alipay sicuri al 100%.
Conto PayPal verificato e sicuro al 100%. Trasferimento in tutto il mondo ad eccezione dei paesi vietati / inseriti nella lista nera.

PayPal
Prezzo dell'importo del trasferimento
€ 5.000 Trasferimento = € 700
€ 10.000 Trasferimento = € 1.400

Alipay
Prezzo dell'importo del trasferimento
¥ 38.000 CNY Transfer = ¥ 5600
¥ 76.000 CNY Transfer = ¥ 11.200

Contatta da:
Telegram: Digitalmarkt

controlla il canale su Telegram!
https://t.me/bestfinancialmarket
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Lun, 27/01/2020 - 10:04
cattiware ha scritto:Perfetto, come previsto era la versione del kernel (4.19.x) poco aggiornata. Adesso ho installato la "5.4.0-0.bpo.2-amd64", e funziona tutto
Felice di esserti stato d'aiuto. Diciamo che per il pieno supporto di alcune componenti (batteria) dell'harware che stai utilizzando è necessaria una versione del kernel più recente di quella attualmente disponibile con Debian Stable.
Categorie: Forum Debianizzati

Re: [RISOLTO] Possible missing firmware

Lun, 27/01/2020 - 10:01
Felice di esserti stato d'aiuto.
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Lun, 27/01/2020 - 10:01
Potresti rigenerare il log per le due installazioni con i comandi di seguito riportati ?
script log-"$(uname -r).txt"
cat /sys/class/dmi/id/product_uuid
systemctl --no-pager list-units
systemd-analyze --no-pager critical-chain
systemd-analyze --no-pager blame
exit
Categorie: Forum Debianizzati

Re: Prestazioni inferiori al dovuto

Lun, 27/01/2020 - 00:06
Grazie per la risposta. La sua gentilezza conferma la bellezza di questa meravigliosa comunità.

1) Sul tema del processore mi è venuto un'enorme dubbio! Il processore in questione è un Quad-Core; la velocità di Clock non dovrebbe quadruplicare rispetto ai 2 Ghz del solo processore (o comunque essere di gran lunga maggiore rispetto a un Single Core di 3 Ghz)? Ricordo che ho giocato senza problema a titoli piuttosto pesanti, come Crysis 1, con impostazioni al massimo ma senza notare alcun rallentamento in merito;

2) A dire il vero altri titoli, come Counter Strike GO girano senza problemi con grafica impostata al massimo, tranne dei rallentamenti duranti le fasi più concitate con parecchi giocatore collegati alla partita (suppongo tuttavia di un problema di Ping).

3) Seguendo la guida indicata ho installato (?) le librerie a 32 bit tramite:
apt install nvidia-driver nvidia-driver-libs-i386 nvidia-vulkan-icd nvidia-vulkan-icd:i386
mentre ho eliminato i driver Mesa con
apt-get remove libgl1:i386 mesa-vulkan-drivers:i386 mesa-vulkan-drivers
Dovrebbe essere tutto a posto il lato grafico della questione (o almeno spero).

4) Inizio seriamente a sospettare che sia un problema di RAM. Affronterò il test richiesto e vedrò quanta RAM viene consumata durante l'esecuzione di tali programmi.

Grazie mille per l'aiuto. A presto porterò degli aggiornamenti in merito.

Edit: l'eliminazione delle librerie Open Source, a dire il vero, non è completa, in quanto eliminando la libreria libgl1:i386 il gestore pacchetti mi obbliga a eliminare direttamente il software Steam:

root@debian:/home/famiglia# apt remove libgl1:i386
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libegl-mesa0:i386 libegl-nvidia0:i386 libegl1:i386 libgbm1:i386
  libgles-nvidia1:i386 libgles-nvidia2:i386 libgles1:i386 libgles2:i386
  libgpg-error0:i386 libnvidia-eglcore:i386 libopengl0:i386 libudev1:i386
  libwayland-client0:i386 libwayland-server0:i386 libxcb-xfixes0:i386
  libxinerama1:i386 libxss1:i386 nvidia-egl-icd:i386 steam-devices
Usare "apt autoremove" per rimuoverli.
I seguenti pacchetti saranno RIMOSSI:
  libgl1:i386 libgl1-mesa-glx:i386 libgl1-nvidia-glvnd-glx:i386
  nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386 steam:i386
0 aggiornati, 0 installati, 6 da rimuovere e 0 non aggiornati.
Dopo quest'operazione, verranno liberati 5.892 kB di spazio su disco.
Continuare? [S/n]


Ciò è strano: in quanto l'installazione di tale libreria (in accordo con la guida ufficiale Debian) è stata eseguita dopo l'installazione di Steam e un suo completo utilizzo. Perché proprio adesso è divenuta indispensabile mentre prima non lo era?
Categorie: Forum Debianizzati

Re: LENOVO IDEAPAD Batteria non riconosciuta...

Dom, 26/01/2020 - 23:41
Perfetto, come previsto era la versione del kernel (4.19.x) poco aggiornata. Adesso ho installato la "5.4.0-0.bpo.2-amd64", e funziona tutto (salvo eventuali bug che potrei riscontrare...)! Anche Wifi e Bluetooth, senza mettere nulla in blacklist.
Dichiaro la questione risolta in modo definitivo, e spero che possa essere d'aiuto a qualcun altro nella mia situzione precedente.

Intanto volevo spiegare quello che ho fatto (utilizzando Debian 10 Buster (Stable):

- ho aggiunto al file:
sudo nano /etc/apt/sources.list

la seguente riga (per la buster-backend):
deb http://deb.debian.org/debian buster-backports main

- ho aggiornato i repository software
sudo apt update

- ho cercato i vari kernel disponibili:
sudo apt -t buster-backports search linux-image

- trovato il kernel, l'ho installato (nel mio caso):
sudo apt -t buster-backports install linux-image-5.4.0-0.bpo.2-amd64


Il primo risultato che son riuscito a vedere sono le reti wireless e, lo scopo dell'argomento, lo stato della batteria del laptop!

---
Maggiori info:
https://backports.debian.org/

Grazie per il supporto,
Alessandro
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 23:02
Ora si presenta cosi':
$ systemd-analyze blame
          3.091s udisks2.service
          2.490s ModemManager.service
          2.421s dev-sda3.device
          2.075s accounts-daemon.service
          1.956s NetworkManager.service
          1.805s vboxdrv.service
          1.717s avahi-daemon.service
          1.715s wpa_supplicant.service
          1.554s rsyslog.service
          1.505s systemd-logind.service
          1.375s systemd-rfkill.service
          1.167s exim4.service
           448ms upower.service
           428ms bluetooth.service
           277ms apparmor.service
           272ms polkit.service
           260ms systemd-udevd.service
           249ms systemd-timesyncd.service
           245ms networking.service
           238ms alsa-restore.service
           161ms packagekit.service
           141ms systemd-journald.service
           140ms systemd-tmpfiles-setup.service
           113ms user@1000.service
            97ms systemd-udev-trigger.service
            89ms pppd-dns.service
            76ms plymouth-quit-wait.service
            74ms plymouth-quit.service

ma l'avvio resta uguale
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 22:55
Piergiusepegiorgio ha scritto:Potrei provare cosi':
$ systemctl stop apt-daily.timer
$ systemctl disable apt-daily.timer
$ systemctl mask apt-daily.service
$ systemctl daemon-reload

Il servizio apt-daily.timer serve ad effettuare l'aggiornamento giornaliero del contenuto dei repository: si può tranquillamente disabilitare ed effettuare quando serve in modo manuale l'aggiornamento con il comando:
apt update
Categorie: Forum Debianizzati

Re: Possible missing firmware

Dom, 26/01/2020 - 22:45
fatto con
update-initramfs -u

al riavvio il warning non si ripresenta

grazie
m
Categorie: Forum Debianizzati

Re: Debian 10.2 kde avvio lento

Dom, 26/01/2020 - 22:33
Piergiusepegiorgio ha scritto:Confrontando l'avvio rispetto a neon kde Debian impiega circa il doppio del tempo. Posto le immagini per un confronto,
Debian

Neon

Si notano alcune voci in piu', e' possibile eliminarle?
Dopo l'eliminazione ho provato a ridare la prima istruzione:
         16.665s apt-daily.service
          3.931s udisks2.service
          3.572s ModemManager.service
          3.047s dev-sda3.device
          2.732s accounts-daemon.service
          2.706s NetworkManager.service
          2.451s networking.service
          2.348s avahi-daemon.service
          2.343s wpa_supplicant.service
          2.308s systemd-logind.service
          2.267s vboxdrv.service
          2.158s rsyslog.service
          2.026s systemd-backlight@backlight:acpi_video0.service
          2.025s systemd-backlight@backlight:intel_backlight.service
          2.023s systemd-backlight@backlight:acpi_video1.service
          1.622s exim4.service
           444ms packagekit.service
           434ms bluetooth.service
           322ms apparmor.service
           318ms systemd-udevd.service
           313ms upower.service
           270ms alsa-restore.service
           239ms pppd-dns.service
           204ms systemd-timesyncd.service
           178ms polkit.service
           163ms systemd-tmpfiles-setup.service
           141ms systemd-journald.service
           137ms plymouth-quit-wait.service

Potrei provare cosi':
$ systemctl stop apt-daily.timer
$ systemctl disable apt-daily.timer
$ systemctl mask apt-daily.service
$ systemctl daemon-reload
Categorie: Forum Debianizzati

Re: Prestazioni inferiori al dovuto

Dom, 26/01/2020 - 22:20
Il_Briga ha scritto: ho seguito pedissequamente tutti i passaggi elencati qui: https://wiki.debian.org/Steam, compresi l'installazione del driver Nvidia e Mesa; sono entrambi necessari?
Installando i driver nvidia non sono necessari quelli mesa (i driver mesa sono molto più lenti di quelli nvidia). Inoltre, dal log che hai inviato risulta che il tuo computer usa una CPU molto poco performante (Intel(R) Celeron(R) CPU J1900 @ 1.99GHz), per cui se noti limitate prestazioni ciò potrebbe (anche ?) essere legato all'utilizzo della CPU al posto della GPU.

Non so se può essere utile effettuare il benchmark tra le installazioni dei due sistemi operativi usando la funzionalità specifica di steam (https://steamcommunity.com/sharedfiles/filedetails/?id=323272765)

Inoltre, sembrerebbe che la CPU che hai installato sia al di sotto dei requisiti di sistema consigliati indicati dal produttore per quanto riguarda la frequenza di clock della CPU:
    Requisiti consigliati:
        OS: Ubuntu 14.04 (64 bit)
        Processore: 3 GHz
        RAM: 8GB
        Grafica: 1GB*
        Disco rigido: 16GB
        Nvidia 700 series+, AMD 6000 series+

Nota, infine, che la versione di Steam disponibile su debian (come non-free) è per architettura i386 e, quindi, vede solo al massimo 4Gbyte di ram ed, inoltre, il driver nvidia deve essere compilato sia per architettura i386 che amd64.
Categorie: Forum Debianizzati

Re: Possible missing firmware

Dom, 26/01/2020 - 22:11
samiel ha scritto:ma poi devo aggiornare initramfs? mai fatto, per cui non vorrei fare grossi guai....
Sì, ma non dovrebbero esserci problemi.
Categorie: Forum Debianizzati