Forum Debianizzati

Re: serial8250: too much work for irq4

Forum Debianizzati - Sab, 10/06/2017 - 11:38
aggiornare da ubuntu 15 a 16 LTS non risolve il problema
Categorie: Forum Debianizzati

Re: [RISOLTO] Stretch kde, sfarfallio

Forum Debianizzati - Sab, 10/06/2017 - 01:37
@s3v

La risposta si trova nella sezione scripting: [Risolto] Creazione script per invio informazioni al forum

http://forum.debianizzati.org/viewtopic.php?f=13&t=45098&p=209588#p209588
Categorie: Forum Debianizzati

Re: [Risolto] Creazione script per invio informazioni al for

Forum Debianizzati - Sab, 10/06/2017 - 01:27
2)
@s3v

In una discussione ho postato due script log riguardanti problemi video, s3v mi ha chiesto:
http://forum.debianizzati.org/viewtopic.php?f=15&p=209583&sid=2f309afb78e7e52529998e232a330d6d#p209583

[OT]

Lioce ha scritto:
Ho omesso tutti gli indirizzi ip perché non pertinenti al problema.


Potresti indicare le parti che hai dovuto modificare?
[/OT]

Mi riferisco al secondo log postato (ma le srtinghe del primo sono identiche)

Queste due stringhe contengono il nome del paese in cui si risiede:

Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=*_omesso_*
Jun  8 21:12:01 nomehost kernel: [   29.450505] ath: Country alpha2 being used: *_omesso_*


Queste contiengono l'ESSID mascherato giustamente dallo script e il suo indirizzo (ripetuto varie volte)
che invece ho mascherato io

Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: SME: Trying to authenticate with *_omesso_* (SSID='*script-removed*' freq=2462 MHz)
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: Trying to associate with *_omesso_* (SSID='*script-removed*' freq=2462 MHz)


Questo è l'elenco completo e ordinato come si trova nello script

Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: SME: Trying to authenticate with *_omesso_* (SSID='*script-removed*' freq=2462 MHz)
Jun  8 21:12:01 nomehost kernel: [   29.405056] wlp4s0: authenticate with *_omesso_*
Jun  8 21:12:01 nomehost kernel: [   29.418447] wlp4s0: send auth to *_omesso_* (try 1/3)
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: Trying to associate with *_omesso_* (SSID='*script-removed*' freq=2462 MHz)
Jun  8 21:12:01 nomehost kernel: [   29.425177] wlp4s0: associate with *_omesso_* (try 1/3)
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: Associated with *_omesso_*
Jun  8 21:12:01 nomehost kernel: [   29.444215] wlp4s0: RX AssocResp from *_omesso_* (capab=0x431 status=0 aid=1)
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=*_omesso_*
Jun  8 21:12:01 nomehost kernel: [   29.450505] ath: Country alpha2 being used: *_omesso_*
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: WPA: Key negotiation completed with *_omesso_* [PTK=CCMP GTK=CCMP]
Jun  8 21:12:01 nomehost wpa_supplicant[2581]: wlp4s0: CTRL-EVENT-CONNECTED - Connection to *_omesso_* completed [id=0 id_str=]
Jun  8 21:12:01 nomehost dhclient[2610]: DHCPREQUEST of *_omesso_* on wlp4s0 to 255.255.255.255 port 67
Jun  8 21:12:01 nomehost dhclient[2610]: DHCPACK of *_omesso_* from *_omesso_*
Jun  8 21:12:01 nomehost avahi-daemon[2509]: Joining mDNS multicast group on interface wlp4s0.IPv4 with address *_omesso_*.
Jun  8 21:12:01 nomehost avahi-daemon[2509]: Registering new address record for *_omesso_* on wlp4s0.IPv4.
Jun  8 21:12:02 nomehost dhclient[2610]: bound to *_omesso_* -- renewal in 411202 seconds.
Jun  8 21:12:03 nomehost avahi-daemon[2509]: Joining mDNS multicast group on interface wlp4s0.IPv6 with address *_omesso_*.
Jun  8 21:12:03 nomehost avahi-daemon[2509]: Registering new address record for *_omesso_* on wlp4s0.*.
Jun  8 21:12:05 nomehost dhclient[2708]: RCV: Reply message on wlp4s0 from *_omesso_*.
Jun  8 21:12:05 nomehost avahi-daemon[2509]: Leaving mDNS multicast group on interface wlp4s0.IPv6 with address *_omesso_*.
Jun  8 21:12:05 nomehost avahi-daemon[2509]: Joining mDNS multicast group on interface wlp4s0.IPv6 with address *_omesso_*.
Jun  8 21:12:05 nomehost avahi-daemon[2509]: Registering new address record for *_omesso_* on wlp4s0.*.
Jun  8 21:12:05 nomehost avahi-daemon[2509]: Withdrawing address record for *_omesso_* on wlp4s0.
Jun  8 21:12:05 nomehost avahi-daemon[2509]: Registering new address record for *_omesso_* on wlp4s0.*.
Jun  8 21:12:31 nomehost wpa_supplicant[2581]: wlp4s0: WPA: Group rekeying completed with *_omesso_* [GTK=CCMP]


So che si tratta di indirizzi dedicati a LAN, uguali in tutto il mondo, ma sono veramente utili alla comprensione
di un problema che non riguarda il network?
Categorie: Forum Debianizzati

Re: [Risolto] Creazione script per invio informazioni al for

Forum Debianizzati - Sab, 10/06/2017 - 01:18
1)
set-hw-addr e domain name in journalctl

Subito dopo un'istallazione di Stretch, al primo riavvio e quindi con systemd *ancora* PID 1, ho eseguito lo
script per invio informazioni al forum, tipo di problema: video.

Versione script: 1.0.62


In journalctl -x -b --no-pager ho trovato queste due stringhe, la seconda rivela l'indirizzo MAC reale della
mia macchina (qui ovviamente omesso)

apr 12 00:57:13 nomehost NetworkManager[485]: <info>  [1491951433.1089] device (wlp4s0): set-hw-addr: set MAC address to XX:XX:XX:XX:XX:XX (scanning)
apr 12 00:57:14 nomehost NetworkManager[485]: <info>  [1491951434.8119] device (wlp4s0): set-hw-addr: reset MAC address to YY:YY:YY:YY:YY:YY (preserve)


Più giù ho trovato quest'altra stringa che invece rivela il nome reale del dominio (anche questo ovviamente omesso)

apr 12 00:57:15 nomehost NetworkManager[485]: <info>  [1491951435.7920] dhcp4 (wlp4s0):   domain name '*omesso_dall'utente*'


Forse gli utenti Debian che non usano sysvinit sono pochi, mi chiedo però se non sia il caso di creare una funzione
nello script per risolvere questo problema.

EDIT
Preciso che non ho inviato al forum il log di questo script ma che l'ho fatto solo per me.
Ho reinstallato due o tre volte e ho constatato che queste informazioni erano sempre presenti in journalctl -x -b --no-pager.
Categorie: Forum Debianizzati

Re: collegare due rete di computer

Forum Debianizzati - Ven, 09/06/2017 - 15:12
ho messo un router tra le due reti, che mi fa da nat
Categorie: Forum Debianizzati

Re: come settare DPI manualmente

Forum Debianizzati - Ven, 09/06/2017 - 12:03
Il driver in uso lo ricavi dal comando:
# lspci -knn

e scorrere l'output per trovare la VGA.
Dal file che hai allegato non si riesce a risalirvi, forse ti manca qualche pacchetto (che spiegherebbe anche la risoluzione errata).

Vedi anche:
http://guide.debianizzati.org/index.php ... i_al_forum
Categorie: Forum Debianizzati

Re: come settare DPI manualmente

Forum Debianizzati - Ven, 09/06/2017 - 11:45
ho aggiunto la sezione device, ma che parametro devo mettere per "Driver"? Ho una Intel HD 530 e non riesco a capire quale sia il driver corretto. Se uso "intel" xorg si incazza perché la mia scheda non è tra quelle supportate

grazie
Categorie: Forum Debianizzati

Re: [RISOLTO] Stretch kde, sfarfallio

Forum Debianizzati - Ven, 09/06/2017 - 09:54
Felice che tu abbia risolto.
Per gli altri problemi ti invito ad aprire discussioni separate allo scopo di mantenere un'uniformità logica a vantaggio di chi dovesse leggere.
[OT]
Lioce ha scritto:Ho omesso tutti gli indirizzi ip perché non pertinenti al problema.

Potresti indicare le parti che hai dovuto modificare?
[/OT]
Categorie: Forum Debianizzati

Re: [RISOLTO] Stretch kde, sfarfallio

Forum Debianizzati - Ven, 09/06/2017 - 09:54
Felice che tu abbia risolto.
Per gli altri problemi ti invito ad aprire discussioni separate allo scopo di mantenere un'uniformità logica a vantaggio di chi dovesse leggere.
[OT]
Lioce ha scritto:Ho omesso tutti gli indirizzi ip perché non pertinenti al problema.

Potresti indicare le parti che hai dovuto modificare?
[/OT]
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Gio, 08/06/2017 - 23:32
Confermo che il malfunzionamento è definitivamente scomparso.

Non solo: è scomparso dai log anche l'errore che ho segnalato nel primo post di questa discussione:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun


Ora in dmesg ho:

# dmesg | grep -i error
[    0.393957] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[   14.916732] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro

# dmesg | grep ERROR
[    0.393957] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM

# dmesg -l err
[   17.330179] ip_local_port_range: prefer different parity for start/end values.
[   31.232089] systemd-logind[2694]: Failed to start user service, ignoring: Unknown unit: user@114.service
[   48.983395] systemd-logind[2694]: Failed to start user service, ignoring: Unknown unit: user@1000.service


Ho eseguito un altro script-log che allego, se vi può interessare.

Ringrazio di nuovo tutti quelli che mi hanno aiutato.

P.S.
Prima di iniziare questa discussione ho fatto ricerche su drm, i915, PCH transcoder ecc., ma non ricordo di essermi
imbattuto nei problemi di accelerazione SNA e UXA (o, più probabilmente, non ho capito niente di quello che stavo leggendo!)
Ora vedo che in rete c'é una grande quantità di materiale.
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Gio, 08/06/2017 - 23:32
Confermo che il malfunzionamento è definitivamente scomparso.

Non solo: è scomparso dai log anche l'errore che ho segnalato nel primo post di questa discussione:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun


Ora in dmesg ho:

# dmesg | grep -i error
[    0.393957] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[   14.916732] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro

# dmesg | grep ERROR
[    0.393957] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM

# dmesg -l err
[   17.330179] ip_local_port_range: prefer different parity for start/end values.
[   31.232089] systemd-logind[2694]: Failed to start user service, ignoring: Unknown unit: user@114.service
[   48.983395] systemd-logind[2694]: Failed to start user service, ignoring: Unknown unit: user@1000.service


Ho eseguito un altro script-log che allego, se vi può interessare.

Ringrazio di nuovo tutti quelli che mi hanno aiutato.

P.S.
Prima di iniziare questa discussione ho fatto ricerche su drm, i915, PCH transcoder ecc., ma non ricordo di essermi
imbattuto nei problemi di accelerazione SNA e UXA (o, più probabilmente, non ho capito niente di quello che stavo leggendo!)
Ora vedo che in rete c'é una grande quantità di materiale.
Categorie: Forum Debianizzati

Re: Xsession cannot write to /tmp X may exit with errors"

Forum Debianizzati - Gio, 08/06/2017 - 20:54
samiel ha scritto:Direi che tutto procede bene
Fermo restando che no capisco perché il manutenbtore
non sistema il pacchetto....
Puoi proporre tu una patch
Categorie: Forum Debianizzati

Re: Xsession cannot write to /tmp X may exit with errors"

Forum Debianizzati - Gio, 08/06/2017 - 18:54
Direi che tutto procede bene
Fermo restando che no capisco perché il manutenbtore
non sistema il pacchetto....

m
Categorie: Forum Debianizzati

Re: come settare DPI manualmente

Forum Debianizzati - Gio, 08/06/2017 - 10:24
Ti serve una sezione "Device" al cui interno sono necessarie almeno le opzioni "Identifier" e "Driver".
Categorie: Forum Debianizzati

Re: Icinga 2 e verifica del file di configurazione

Forum Debianizzati - Gio, 08/06/2017 - 10:16
--validate è un opzione del daemon mode, quindi:
icinga2 daemon --validate o anche icinga2 daemon -C
ciao
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Gio, 08/06/2017 - 01:26
@allinone: grazie per il tuo intervento.
@s3v: ottimo consiglio, grazie.

s3v ha scritto:Questo sembra simile al tuo problema.

Sì, il problema è proprio quello: "flickering and flashing", a parte sddm su cui non l'ho mai avuto.

Ho creato un file /etc/X11/xorg.conf.d/20-intel.conf contenente:

cat /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection


ho riavviato e il malfunzionamento sembra definitivamente scomparso, anche con gli effetti del desktop abilitati all'avvio e motore di rendering OpenGl 2.0 (come da default).

Vedo se la situazione, dopo qualche riavvio, rimane stabile e poi vi informo.
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Gio, 08/06/2017 - 01:26
@allinone: grazie per il tuo intervento.
@s3v: ottimo consiglio, grazie.

s3v ha scritto:Questo sembra simile al tuo problema.

Sì, il problema è proprio quello: "flickering and flashing", a parte sddm su cui non l'ho mai avuto.

Ho creato un file /etc/X11/xorg.conf.d/20-intel.conf contenente:

cat /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection


ho riavviato e il malfunzionamento sembra definitivamente scomparso, anche con gli effetti del desktop abilitati all'avvio e motore di rendering OpenGl 2.0 (come da default).

Vedo se la situazione, dopo qualche riavvio, rimane stabile e poi vi informo.
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Mer, 07/06/2017 - 19:00
Vi lascio anche la mia testimonianza, dove, con una scheda grafica come questa,

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)

con driver intel installati e con una grafica, in alcune finestre, per esempio nel menù di firefox, "corrotta"
ho risolto aggiungendo/specificando in /etc/X11/xorg.conf.d/cat 20-intel.conf
Option "AccelMethod" "uxa"


Un saluto, Andrea.
Categorie: Forum Debianizzati

Re: Stretch kde, sfarfallio

Forum Debianizzati - Mer, 07/06/2017 - 19:00
Vi lascio anche la mia testimonianza, dove, con una scheda grafica come questa,

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)

con driver intel installati e con una grafica, in alcune finestre, per esempio nel menù di firefox, "corrotta"
ho risolto aggiungendo/specificando in /etc/X11/xorg.conf.d/cat 20-intel.conf
Option "AccelMethod" "uxa"


Un saluto, Andrea.
Categorie: Forum Debianizzati

Icinga 2 e verifica del file di configurazione

Forum Debianizzati - Mer, 07/06/2017 - 15:55
Ciao a tutti, sono alle prese con la configurazione di icinga2 su debian stretch.
Probabilmente aprirò diversi post su questo argomento.

Comimincio con quella che dovrebbe essere una banalità.
Nella versione 1 di cinga per verificare la correttezza della configurazione si esegu
icinga -v /etc/icinga/icinga.conf
In icinga 2, stando la man dovrebbe essere
icinga2 --validate

man icinga2
       -C, --validate
              This option can be used to check if your configuration files contain errors.  If any errors are found the exit status is 1, otherwise 0 is returned.


ma ottengo il messaggio

critical/icinga-app: Error while parsing command-line options: unrecognised option '--validate'


come se avessi sbagliato sintassi.
version: r2.6.0-1.
Categorie: Forum Debianizzati
Condividi contenuti