Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - 1 ora 15 min fa
Et voilà
Jan 18 09:57:25 swalf-asus kernel: [17517.514986] usb 1-1: new high-speed USB device number 11 using xhci_hcd
Jan 18 09:57:25 swalf-asus kernel: [17517.656256] usb 1-1: New USB device found, idVendor=13fe, idProduct=3100
Jan 18 09:57:25 swalf-asus kernel: [17517.656272] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jan 18 09:57:25 swalf-asus kernel: [17517.656275] usb 1-1: Product: 2233 PRAM               
Jan 18 09:57:25 swalf-asus kernel: [17517.656278] usb 1-1: Manufacturer:                         
Jan 18 09:57:25 swalf-asus kernel: [17517.657189] usb-storage 1-1:1.0: USB Mass Storage device detected
Jan 18 09:57:25 swalf-asus kernel: [17517.657624] scsi host4: usb-storage 1-1:1.0
Jan 18 09:57:25 swalf-asus systemd-udevd[7804]: failed to execute '/lib/udev/mtp-probe' 'mtp-probe /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1 1 11': No such file or directory
Jan 18 09:57:26 swalf-asus kernel: [17518.687539] scsi 4:0:0:0: Direct-Access              2233 PRAM        1.00 PQ: 0 ANSI: 0 CCS
Jan 18 09:57:26 swalf-asus kernel: [17518.688937] sd 4:0:0:0: Attached scsi generic sg1 type 0
Jan 18 09:57:26 swalf-asus kernel: [17518.690711] sd 4:0:0:0: [sdb] Attached SCSI removable disk
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - 1 ora 27 min fa
Proviamo anche questo per avere qualche dettaglio in più rispetto al log su messages:
tail -f /var/log/syslog
Lasciando sempre aperta la shell in primo piano ed inserisci la memoria usb nella relativa porta.
Posta ancora le righe di log che appaiono.
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - 1 ora 54 min fa
Ciao,
ecco in risultati di sg_scan e sg_map
sg_scan #senza chiavetta
/dev/sg0: scsi0 channel=0 id=0 lun=0 [em]
sg_map #senza chiavetta
/dev/sg0  /dev/sda
sg_scan #con la chiavetta
/dev/sg0: scsi0 channel=0 id=0 lun=0 [em]
/dev/sg1: scsi4 channel=0 id=0 lun=0 [em]
sg_map ##con la chiavetta
/dev/sg0  /dev/sda
/dev/sg1  /dev/sdb

Grazie per l'aiuto
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - 8 ore 26 min fa
Anche io volevo formattare una memoria usb ma Gparted non la vedeva e allora ho risolto usando Gparted live, ma poi controllando meglio ho visto che aprendo Gparted con la penna usb già montata viene rilevata poi ovviamente smontandola da dentro Gparted si possono fare le varie operazioni
Categorie: Forum Debianizzati

Re: [Strech] Risoluzione schermo con intel

Forum Debianizzati - Mer, 18/01/2017 - 00:13
Ah trovato per il punto 2) !
Grazie alle spiegazioni trovate qua ho capito che l'errore insorge se tento di creare un mode già esistente al riavvio precedente...
Però non so come poter rendere la modifica definitiva se ad ogni volta occorre creare un nuovo mode, nel file /etc/X11/Xsession.d/45x11-xrandr basterebbe:
xrandr --output VGA-1 --mode 1280x1024_60.00
?
peccato che non riesca a riavviare X senza chiudere la sessione (problema 1)

Boh, ho riavviato la sessione e la risoluzione è quella di prima...

grazie intanto!
Categorie: Forum Debianizzati

Re: Ecryptfs automount login con chiave USB

Forum Debianizzati - Mar, 17/01/2017 - 23:54
Se qualcuno dovesse duplicare o "rubare" la tua usb......e poi avere accesso al tuo pc??!!! No è meglio che la passphrase sia "memorizzata" solo nella tua testa??
è proprio per quello che vorrei che decifrasse _dopo_ il login (che presuppone, almeno, la password dell'utente) e non all'avvio/boot del pc...ci vuole e la chiavetta e la password utente o, altrimenti, la passphrase.
Non che sia una sicurezza estrema (infatti, penso che cambiando la password utente si possa riuscire comunque ad accedere al disco, se c'è la chiavetta), ma diciamo che se qualcuno dovesse rubare il pc, dovrebbe bastare.
La chiavetta pensavo di inserirla allo schermo di login, così da evitare che al boot si perda tempo.
Sì sì non voglio fare tutta la home come nell'esempio, solo una cartella!
Grazie per i suggerimenti, vi terrò aggiornati, anche se per ora sono insorti altri problemi (vedi qui) che attirano la mia attenzione!
ciao ciao
Categorie: Forum Debianizzati

Re: ltsp si blocca al login utente

Forum Debianizzati - Mar, 17/01/2017 - 23:22
no il login si blocca come al solito tranne che in ssh dove va tutto normale... l'unica differenza è che per me è qualcosa d'altro incraniato da qualche altra parte perché solitamente l'esecuzione di un programma X11 tramite ssh è rapida per i log tutto come al solito non ci stanno errori ad esclusione di quelli già messi prima su pastebin... o meglio ora gli unici errori che mi da sono sempre

Xsession: X session started for ermac at Tue Jan 17 14:35:08 CET 2017
xrdb: Connection reset by peer
xrdb: Can't open display 'localhost:11.0'
xhost: unable to open display "localhost:11.0"
Xsession: X session started for ermac at Tue Jan 17 14:57:03 CET 2017

** (x-session-manager:12076): WARNING **: Cannot open display:
xrdb: Connection reset by peer
xrdb: Can't open display 'localhost:11.0'
Xsession: X session started for ermac at Tue Jan 17 14:59:48 CET 2017
xrdb: Connection reset by peer
xrdb: Can't open display 'localhost:11.0'
xhost: unable to open display "localhost:11.0"
xhost: unable to open display "localhost:11.0"

** (x-session-manager:12852): WARNING **: Cannot open display:

** (x-session-manager:13016): WARNING **: Cannot open display:
Xsession: X session started for ermac at Tue Jan 17 16:48:34 CET 2017
localuser:ermac being added to access control list

** (x-session-manager:18865): WARNING **: Cannot open display:
Xsession: X session started for ermac at Tue Jan 17 17:11:14 CET 2017
xhost: unable to open display "localhost:11.0"

** (x-session-manager:19058): WARNING **: Cannot open display:
Categorie: Forum Debianizzati

Re: Ecryptfs automount login con chiave USB

Forum Debianizzati - Mar, 17/01/2017 - 22:41
Concordo con la tua scelta per il tutorial di Howtoforge, mi pare il più diretto. Inoltre come consiglia un commentatore tramite udev dovresti poter ottenere il tuo scopo anche a "caldo" dopo il boot. Quindi la chiavetta dovrai inserirla dopo il login, o forse vorresti averla già inserita prima? O addirittura prima del boot?
Ricordati comunque di cryptare solo le directory che ti interessano e non tutta la home.
Fai attenzione quando copy la directory da cryptare in /tmp.....in caso di reboot senza aver prima fatto un backup potrebbe essere un problema...
Mi sorge anche un dubbio.....
Se qualcuno dovesse duplicare o "rubare" la tua usb......e poi avere accesso al tuo pc??!!! No è meglio che la passphrase sia "memorizzata" solo nella tua testa??
Comunque aggiornaci sui tuoi progressi....la questione è interessante!

Ciao
Categorie: Forum Debianizzati

[Strech] Risoluzione schermo con intel

Forum Debianizzati - Mar, 17/01/2017 - 21:41
Ciao a tutti!
Allora, sono felice di annunciarvi che ho un nuovo pc fisso!
Il che non credo vi interessi, ma purtroppo per voi, vuol dire anche nuovi problemi irrisolvibili...

Innanzitutto, vorrei settare correttamente la risoluzione dello schermo.

Prima di elencarvi le operazioni da me eseguite, ecco qualche elemento hardware:
tarmac@debian:~$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06)

Il che se ho capito bene, corrisponde a una HD Graphics intel 4000 series.
Sempre da quanto ho capito, usa i driver intel:
ttarmac@debian:~$ lsmod | grep i915
i915                 1282048  16
drm_kms_helper        155648  1 i915
drm                   360448  8 i915,drm_kms_helper
i2c_algo_bit           16384  1 i915
video                  40960  1 i915
button                 16384  1 i915


Per quanto riguarda, invece, lo schermo, si tratta di un vecchio schermo piatto (già marca "Daewoo telecom Europe" non lascia presagire niente di buono) che vorrei settare a 1280x1024 a 60hz.

La procedura eseguita in un primo tempo è stata questa:
$xrandr --newmode $(gtf 1280 1024 60 | sed -ne 's/"//g;s/ Modeline //p')^C

seguito da
xtarmac@debian:~$ xrandr --addmode VGA-1 1280x1024_60.00

e, infine:
tarmac@debian:~$ xrandr --output VGA-1 --mode 1280x1024_60.00


Il risultato è stato talmente bello che ho voluto renderlo definitivo ad ogni avvio.
Ho dapprima creato un file
/etc/X11/xorg.conf.d/daewoo.conf

con ciò:
Section "Screen"
  Identifier "Screen0"
  Monitor    "Daewoo"
  SubSection "Display"
    Modes "1280x1024_60.00"
  EndSubSection
EndSection

Ma non vedendo cambiamenti, ho lasciato perdere il vetusto xorg e ho inserito questo nuovo file:
tarmac@debian:~$ sudo cat /etc/X11/Xsession.d/45x11-xrandr[sudo] password di tarmac:
xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA-1 1280x1024_60.0


E qui...due (brutte) sorprese:

1) la combinazione abituale per passare alla shell senza X (Ctrl+Alt+F1) non sembra più funzionare...inutile dire gli effetti disastrosi di un tentativo di restart di gdm da emulatore di terminale (schermo lampeggiante);
2) al riavvio, non soltanto non ho più la risoluzione che mi sarebbe tanto piaciuta, ma, tentando di rimetterla con xrandr, ottengo un nuovo errore:
tarmac@debian:~$ xrandr --newmode $(gtf 1280 1024 60 | sed -ne 's/"//g;s/ Modeline //p')
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  27
  Current serial number in output stream:  27

Ah, il risultato di xrandr è questo:
tarmac@debian:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00*
   800x600       60.32    56.25 
   848x480       60.00 
   640x480       59.94 
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
  1280x1024_60.00 (0xd5) 109.000MHz -HSync +VSync
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock  63.67KHz
        v: height 1024 start 1027 end 1034 total 1063           clock  59.89Hz

Cos'è successo secondo voi?
E come posso ottenere l'effetto desiderato?

Grazie mille per ogni suggerimento e consiglio sulle prove da fare...
Categorie: Forum Debianizzati

Re: ltsp si blocca al login utente

Forum Debianizzati - Mar, 17/01/2017 - 20:34
coè adesso il login è ok?
per il resto hai già guardato i nuovi log? se non c'è niente di utile diventa difficile cercare una soluzione,
eventualmente se ritieni posta i nuovi log
Categorie: Forum Debianizzati

Ecryptfs automount login con chiave USB

Forum Debianizzati - Mar, 17/01/2017 - 20:21
Ciao a tutti!
Allora, sono alla ricerca di qualche consiglio per:

- creare una cartella criptata (con ecryptfs -- eventualmente con un altro programma che mi permetta di fare quanto segue -- );
- nella mia /home;
- che si auto monti al login utente se c'è un'USB inserita con la passphrase;
- in cui possa conservare il mio profilo di firefox/icedove.

Ovvero, se non ci fosse l'USB per montarsi dovrebbe richiedere la passphrase.
Sto usando Debian 9, appena installata.

La migliore documentazione l'ho trovata qui e qua, ma:
1) si tratta di documentazione un po' vecchia (2009 e febbraio 2016);
2) non è direttamente per Debian (in realtà, penso che questo sia l'ultimo dei problemi);
3) il metodo Archlinux, per ottenere l'automount, consiglia di eseguire uno script (ecryptfs-setup-private) che fa tutto da solo, ma non dà la possibilità di salvare la passphrase su USB, mentre invece:
4) il metodo Ubuntu, se ho capito bene, rende in chiaro i dati _all'avvio_ e non al login se c'è la chiavetta (il che vuol dire che se c'è la chiavetta, anche un altro utente potrebbe avere accesso alla cartella criptata, che io però vorrei solo accessibile dal mio utente).

Quindi mi rivolgo a voi per capire come procedere.
Quiconsigliano uno script, ma mi sembra un po' macchinoso (anche perché non so se ho capito proprio bene!).
Anche qua spiegano passo a passo come fare, ma sempre con il problema (non sono sicura) che me la decifri all'avvio e non al login...
E l'altra cosa di cui vorrei conferma è: se tolgo l'usb (o se per sfortuna si rompesse, ad esempio) basterà reinserire la passphrase per decifrare i dati, no?

Quindi non mi resta che ringraziarvi per i vostri consigli e le vostre eventuali esperienze...
Non ho allegato log o altre informazioni perché mi sembrano superflue (dal momento che, per ora, non si tratta di un problema software/hardware da risolvere), casomai però ce ne fosse bisogno, fate un fischio.
Nel frattempo penso comunque che seguirò il tutorial di howtoforge e vi farò sapere.
Grazie a presto
Categorie: Forum Debianizzati

Re: ltsp si blocca al login utente

Forum Debianizzati - Mar, 17/01/2017 - 17:35
ciao allora in pratica quel "server" dovrebbe andare a dare un po più di velocità a 4 mini pc acer r3600 con intel atom 1,6G e scheda grafica invidia ion primo modello che erano stati usati fino ad ora ma che ormai sono troppo vecchi (7 anni...) e lenti per funzionare indipendentemente.

Quel modulo che lui dice che non riesce a caricare sono i driver open di nvidia "xserver-xorg-video-nouveau" ma per ora era un rimasuglio di quando provavo fare i test infatti nei log successivi non da più quegli errori.

Oggi ho provato fare un altro test cioè tramite client ssh -X a lanciare firefox da remoto ed effettivamente parte ma moltooooooooto lentamente circa 10 minuti quindi deve esserci qualcosa che crea casini ma non riesco veramnte a capire cosa possa essere
Categorie: Forum Debianizzati

Re: Guida Installare Adobe Flash Player

Forum Debianizzati - Mar, 17/01/2017 - 17:01
Grazie per l'info.
Attendo ad aggiornare la guida,il pacchetto non è ancora disponibile per Stretch (testing).
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - Mar, 17/01/2017 - 15:11
prova a dare questi due comandi e posta il risultato: (sia con la memoria usb inserita che senza)
sg_map
sg_scan

Più per cusiosità che altro, ma ora riesci ad accedere alla memoria usb?
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - Mar, 17/01/2017 - 15:04
su sg1 funziona:
dd if=/dev/zero of=/dev/sg1 bs=512 count=1
1+0 record dentro
1+0 record fuori
512 bytes copied, 0,00118678 s, 431 kB/s

Ad ogni modo dopo non sembra cambiare molto dopo la procedura.
fdisk -l vede solo la sd interna sda:

Disk /dev/sda: 238,5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x6627b099

Device     Boot    Start       End   Sectors   Size Id Type
/dev/sda1  *        2048  82030591  82028544  39,1G 83 Linux
/dev/sda2       82030592  85936127   3905536   1,9G 82 Linux swap / Solaris
/dev/sda3       85936128 500117503 414181376 197,5G 83 Linux
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - Mar, 17/01/2017 - 13:36
prova a ripeter le mie istruzioni con /dev/sg1 (se non lo hai già fatto)
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - Mar, 17/01/2017 - 13:25
fdisk -l

cosa ti ritorna?
Categorie: Forum Debianizzati

Re: Ripristinare chiavette dopo dd

Forum Debianizzati - Mar, 17/01/2017 - 13:18
Come scritto, il problema sta proprio nel fatto che per i suddetti programmi la periferica non esiste:
libparted : 3.2
Error opening /dev/sdb: Nessun supporto trovato
fdisk: cannot open /dev/sdb: Nessun supporto trovato
dd: apertura di '/dev/sdb' non riuscita: Nessun supporto trovato
Categorie: Forum Debianizzati

Apache2 Configurazione Script VHOST ----SO Debian Stretch

Forum Debianizzati - Mar, 17/01/2017 - 13:04
Buongiorno a tutti,
ho installato LAMP in stretch e vorrei configurare i vhost in modo da poterli utilizzare su piu pc e non dover rifare le configurazioni ogni volta e modificare il meno possibile.
Nel file che utilizzo per caricare i vhost come e se posso utilizzare la variabile ServerName per reindirizzare i log in una cartella unica ma con il nome del vhost.
definendo la variabile APACHE2_MY_DIR_VHOST in envvars cambio la mia main root dei progetti e fin qui tutto ok.
##test.loc
<VirtualHost *:80>
ServerAdmin webmaster@test.loc
DocumentRoot ${APACHE2_MY_DIR_VHOST}/PhpProject1
ServerName test.loc
ServerAlias http://www.test.loc
?? ErrorLog logs/${ServerName}-errore.log
CustomLog "logs/test.loc-access.log" common
<Directory ${APACHE2_MY_DIR_VHOST}/PhpProject1/>
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted
</Directory>
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel debug
</VirtualHost>

Grazie
Categorie: Forum Debianizzati
Condividi contenuti